icu: tweak icu-config exec_prefix output
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 24 Feb 2011 11:41:31 +0000 (08:41 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 24 Feb 2011 19:54:29 +0000 (20:54 +0100)
Closes #3259

We need to tweak icu-config's exec_prefix too, otherwise if the host
system lacks icu the build fails when looking for the libraries in
/usr/lib rather than the staging directory.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/icu/icu.mk

index ffea1f194f1453b7aa7420518a1caaa1d07948c4..4eddb11a3c081a6b4cc64e331ce3e51f641463a0 100644 (file)
@@ -16,7 +16,9 @@ ICU_SUBDIR = source
 HOST_ICU_SUBDIR = source
 
 define ICU_PREFIX_FIXUP
-       $(SED) "s,^default_prefix=.*,default_prefix=\'$(STAGING_DIR)/usr\',g" $(STAGING_DIR)/usr/bin/icu-config
+       $(SED) "s,^default_prefix=.*,default_prefix=\'$(STAGING_DIR)/usr\',g" \
+               -e "s,^exec_prefix=.*,exec_prefix=\'$(STAGING_DIR)/usr\',g" \
+               $(STAGING_DIR)/usr/bin/icu-config
 endef
 
 ICU_POST_INSTALL_TARGET_HOOKS += ICU_PREFIX_FIXUP