ptpd2: systemd support
authorAlex Suykov <alex.suykov@gmail.com>
Sat, 23 May 2015 10:06:47 +0000 (13:06 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 10:13:41 +0000 (12:13 +0200)
Following package and sysv initscript naming scheme,
the service is "ptpd2" instead of just "ptpd" version 2.

[Thomas:
  - use relative symlink instead of an absolute symlink
  - remove the -s option, which redirects stdout, since systemd will
    take care of it
  - add the -g option, to be consistent with what the init script is
    using.]

Signed-off-by: Alex Suykov <alex.suykov@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ptpd2/ptpd2.mk
package/ptpd2/ptpd2.service [new file with mode: 0644]

index e1d4f2754a69264050d889a1f6212a695640454c..6b2e6bcaca04025dc405e3f0f3eb74c5a850090c 100644 (file)
@@ -29,4 +29,12 @@ define PTPD2_INSTALL_INIT_SYSV
                $(TARGET_DIR)/etc/init.d/S65ptpd2
 endef
 
+define PTPD2_INSTALL_INIT_SYSTEMD
+       $(INSTALL) -D -m 644 package/ptpd2/ptpd2.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/ptpd2.service
+       mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
+       ln -sf ../../../../usr/lib/systemd/system/ptpd2.service \
+               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/ptpd2.service
+endef
+
 $(eval $(autotools-package))
diff --git a/package/ptpd2/ptpd2.service b/package/ptpd2/ptpd2.service
new file mode 100644 (file)
index 0000000..66e71ce
--- /dev/null
@@ -0,0 +1,10 @@
+[Unit]
+Description=Precision Time Protocol daemon
+After=syslog.target network.target
+
+[Service]
+ExecStart=/usr/sbin/ptpd2 -C -g
+Restart=always
+
+[Install]
+WantedBy=multi-user.target