package/rpm: add optional dbus dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 30 Mar 2019 14:49:44 +0000 (15:49 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 31 Mar 2019 13:02:13 +0000 (15:02 +0200)
It should be noted that dbus is enabled by default

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/rpm/rpm.mk

index 0eb6e7f3c7b1a4aba6cab343388ad10709e0907d..fe9f898bd3e2756245ecd1329b380ac224873310 100644 (file)
@@ -35,6 +35,13 @@ else
 RPM_CONF_OPTS += --without-acl
 endif
 
+ifeq ($(BR2_PACKAGE_DBUS),y)
+RPM_DEPENDENCIES += dbus
+RPM_CONF_OPTS += --enable-plugins
+else
+RPM_CONF_OPTS += --disable-plugins
+endif
+
 ifeq ($(BR2_PACKAGE_LIBCAP),y)
 RPM_DEPENDENCIES += libcap
 RPM_CONF_OPTS += --with-cap