fixup lsof so it will apply patches, and compile when rpc is disabled
authorEric Andersen <andersen@codepoet.org>
Fri, 25 Aug 2006 02:13:46 +0000 (02:13 -0000)
committerEric Andersen <andersen@codepoet.org>
Fri, 25 Aug 2006 02:13:46 +0000 (02:13 -0000)
package/lsof/lsof-noportmap.patch [new file with mode: 0644]
package/lsof/lsof.mk

diff --git a/package/lsof/lsof-noportmap.patch b/package/lsof/lsof-noportmap.patch
new file mode 100644 (file)
index 0000000..7101fd7
--- /dev/null
@@ -0,0 +1,18 @@
+--- lsof_4.77/lsof_4.77_src/print.orig.c       2006-08-23 13:37:43.000000000 -0600
++++ lsof_4.77/lsof_4.77_src/print.c    2006-08-23 13:38:29.000000000 -0600
+@@ -148,6 +148,7 @@
+ static void
+ fill_portmap()
+ {
++#if !defined __UCLIBC__ || (defined __UCLIBC__ && defined __UCLIBC_HAS_RPC__)
+       char buf[128], *cp, *nm;
+       CLIENT *c;
+       int h, port, pr;
+@@ -266,6 +267,7 @@
+           Pth[pr][h] = pt;
+       }
+       clnt_destroy(c);
++#endif
+ }
index 6d1cef3bad65d14c3f22ac5ac9db0e63e9f7b5e6..6c2966241e2822fcb39445e9502b2ef77a6ac4c8 100644 (file)
@@ -20,6 +20,7 @@ lsof-unpacked: $(LSOF_DIR)/.unpacked
 $(LSOF_DIR)/.unpacked: $(DL_DIR)/$(LSOF_SOURCE)
        $(LSOF_CAT) $(DL_DIR)/$(LSOF_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        (cd $(LSOF_DIR);tar xf lsof_4.77_src.tar;rm -f lsof_4.77_src.tar)
+       toolchain/patch-kernel.sh $(LSOF_DIR) package/lsof/ *.patch
        touch $(LSOF_DIR)/.unpacked
 
 $(LSOF_DIR)/.configured: $(LSOF_DIR)/.unpacked