package/iputils: move binaries to the location also used by Busybox
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 17 Jun 2019 17:17:46 +0000 (19:17 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Mon, 17 Jun 2019 21:20:59 +0000 (23:20 +0200)
iputils installs several programs that are also implemented as applets
in Busybox. Two of these (arping and tftpd) are installed by iputils
in /bin, while Busybox installs them in /usr/sbin, causing both to be
present if both iputils and busybox are enabled.

This commit moves the binaries installed by iputils to /usr/sbin, so
that only these are installed (Busybox will be installed later thanks
to its optional dependency on iputils, but it will not override the
tools installed by iputils).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/iputils/iputils.mk

index 8be54b4788b8732d5226012a923f18967fdcbab8..7bd756f0400a84cb2dfc921caf2abd03637db40a 100644 (file)
@@ -52,6 +52,17 @@ endif
 # XSL Stylesheets for DocBook 5 not packaged for buildroot
 IPUTILS_CONF_OPTS += -DBUILD_MANS=false -DBUILD_HTML_MANS=false
 
+# move iputils binaries to the same location as where Busybox installs
+# the corresponding applets, so that we have a single version of the
+# tools (from iputils)
+define IPUTILS_MOVE_BINARIES
+       mv $(TARGET_DIR)/usr/bin/arping $(TARGET_DIR)/usr/sbin/arping
+       $(if $(BR2_ROOTFS_MERGED_USR),,\
+               mv $(TARGET_DIR)/usr/bin/ping $(TARGET_DIR)/bin/ping)
+       mv $(TARGET_DIR)/usr/bin/tftpd $(TARGET_DIR)/usr/sbin/tftpd
+endef
+IPUTILS_POST_INSTALL_TARGET_HOOKS += IPUTILS_MOVE_BINARIES
+
 # handle permissions ourselves
 IPUTILS_CONF_OPTS += -DNO_SETCAP_OR_SUID=true
 define IPUTILS_PERMISSIONS