python-dicttoxml: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Fri, 22 Jul 2016 06:36:34 +0000 (08:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 23 Jul 2016 12:57:17 +0000 (14:57 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-dicttoxml/Config.in [new file with mode: 0644]
package/python-dicttoxml/python-dicttoxml.hash [new file with mode: 0644]
package/python-dicttoxml/python-dicttoxml.mk [new file with mode: 0644]

index 6a84f9fbcaca6f3c0ab64b2ddf9707cc55db9312..6b5b011a817c879b08bf190e00ee6f4bb721e0f8 100644 (file)
@@ -656,6 +656,7 @@ menu "External python modules"
        source "package/python-dateutil/Config.in"
        source "package/python-dialog/Config.in"
        source "package/python-dialog3/Config.in"
+       source "package/python-dicttoxml/Config.in"
        source "package/python-django/Config.in"
        source "package/python-docopt/Config.in"
        source "package/python-dominate/Config.in"
diff --git a/package/python-dicttoxml/Config.in b/package/python-dicttoxml/Config.in
new file mode 100644 (file)
index 0000000..152afbb
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_DICTTOXML
+       bool "python-dicttoxml"
+       select BR2_PACKAGE_PYTHON_PYEXPAT if BR2_PACKAGE_PYTHON
+       select BR2_PACKAGE_PYTHON3_PYEXPAT if BR2_PACKAGE_PYTHON3
+       help
+         Converts a Python dictionary or other native data type into a valid
+         XML string.
+
+         https://github.com/quandyfactory/dicttoxml
diff --git a/package/python-dicttoxml/python-dicttoxml.hash b/package/python-dicttoxml/python-dicttoxml.hash
new file mode 100644 (file)
index 0000000..32ba6b0
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/dicttoxml/json, sha256 locally computed
+md5    ec5643a048cf32dad3c28db236b923e4  dicttoxml-1.7.4.tar.gz
+sha256 ea44cc4ec6c0f85098c57a431a1ee891b3549347b07b7414c8a24611ecf37e45  dicttoxml-1.7.4.tar.gz
diff --git a/package/python-dicttoxml/python-dicttoxml.mk b/package/python-dicttoxml/python-dicttoxml.mk
new file mode 100644 (file)
index 0000000..6976715
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-dicttoxml
+#
+################################################################################
+
+PYTHON_DICTTOXML_VERSION = 1.7.4
+PYTHON_DICTTOXML_SOURCE = dicttoxml-$(PYTHON_DICTTOXML_VERSION).tar.gz
+PYTHON_DICTTOXML_SITE = https://pypi.python.org/packages/74/36/534db111db9e7610a41641a1f6669a964aacaf51858f466de264cc8dcdd9
+PYTHON_DICTTOXML_SETUP_TYPE = distutils
+PYTHON_DICTTOXML_LICENSE = GPLv2
+PYTHON_DICTTOXML_LICENSE_FILES = LICENCE.txt
+
+$(eval $(python-package))