gst1-plugins-bad: add Image Quality Assessment (IQA) plugin
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Fri, 12 May 2017 10:18:02 +0000 (11:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Jul 2017 11:31:41 +0000 (13:31 +0200)
This plugin replaces the recently removed videomeasure plugin.

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index f20eb6a4d21d96e1176385cd503d26f8c8b6ada1..f1a1b8ad7cee423db1dd080a00ad02fa0e8f79b6 100644 (file)
@@ -185,7 +185,11 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_TTA
 
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VIDEOMEASURE
        bool "videomeasure removed"
+       select BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_IQA
        select BR2_LEGACY
+       help
+         videomeasure plugin has been removed and has been replaced by
+         iqa, which has automatically been enabled.
 
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_APEXSINK
        bool "apexsink removed"
index d137a6c2538445e423a45dd976213648ddf3376e..35d3f1682c6491f1f47f7ea28f88d3c64fa54701 100644 (file)
@@ -407,6 +407,11 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VIDEOFRAME_AUDIOLEVEL
        help
          videoframe_audiolevel
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_IQA
+       bool "iqa"
+       help
+         Image Quality Assessment
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VIDEOPARSERS
        bool "videoparsers"
        help
index 9dbde1489befc8dfc146458f0681bdcdbc453c71..f597065f1b4eb9f355750e75dda4787aafcf44f0 100644 (file)
@@ -476,6 +476,12 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-videoframe_audiolevel
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_IQA),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-iqa
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-iqa
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VIDEOPARSERS),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-videoparsers
 else