package/shairport-sync: add audio DSP convolution option
authorJörg Krause <joerg.krause@embedded.rocks>
Tue, 3 Dec 2019 10:53:39 +0000 (11:53 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 8 Dec 2019 22:06:25 +0000 (23:06 +0100)
Already in version 3.1, shairport-sync added audio DSP convolution support. This
optional feature requires the sndfile library.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/shairport-sync/Config.in
package/shairport-sync/shairport-sync.mk

index 085a9ec77d0cc468e600b984c71d33f67cb242dc..87f38a940da2bbde2110e43e9a9a650b34c90183 100644 (file)
@@ -20,6 +20,12 @@ config BR2_PACKAGE_SHAIRPORT_SYNC
 
 if BR2_PACKAGE_SHAIRPORT_SYNC
 
+config BR2_PACKAGE_SHAIRPORT_SYNC_CONVOLUTION
+       bool "convolution support"
+       select BR2_PACKAGE_LIBSNDFILE
+       help
+         Enable audio DSP convolution support.
+
 config BR2_PACKAGE_SHAIRPORT_SYNC_LIBSOXR
        bool "libsoxr support"
        select BR2_PACKAGE_LIBSOXR
index 3d9e909879c993120706efb8340c2c861b0aa52d..1ca56e9f0afb532cca2a3f65d432e8a281d5794d 100644 (file)
@@ -51,6 +51,11 @@ SHAIRPORT_SYNC_CONF_LIBS += -lz
 endif
 endif
 
+ifeq ($(BR2_PACKAGE_SHAIRPORT_SYNC_CONVOLUTION),y)
+SHAIRPORT_SYNC_DEPENDENCIES += libsndfile
+SHAIRPORT_SYNC_CONF_OPTS += --with-convolution
+endif
+
 ifeq ($(BR2_PACKAGE_SHAIRPORT_SYNC_LIBSOXR),y)
 SHAIRPORT_SYNC_DEPENDENCIES += libsoxr
 SHAIRPORT_SYNC_CONF_OPTS += --with-soxr