package/domoticz: fix build with cmake < 3.16
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 23 Mar 2020 17:42:21 +0000 (18:42 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 23 Mar 2020 20:24:33 +0000 (21:24 +0100)
Disable precompiled header because it needs cmake >= 3.16 since version
2020.1 and
https://github.com/domoticz/domoticz/commit/2430e5c85624139dd15a74267d6e50992e394509

Fixes:
 - http://autobuild.buildroot.org/results/7c6e5cb35dffa142972ad19594c8cc092cbfaa76

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr:
  - first assignment to CONF_OPTS, so use '=', not '+='
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/domoticz/domoticz.mk

index 6df292764b9207255282d6ecf534d6f68e2817e2..5efe86a7848361e668b797cedd209867ec0ebc95 100644 (file)
@@ -19,6 +19,9 @@ DOMOTICZ_DEPENDENCIES = \
        sqlite \
        zlib
 
+# Disable precompiled header as it needs cmake >= 3.16
+DOMOTICZ_CONF_OPTS = -DUSE_PRECOMPILED_HEADER=OFF
+
 # Due to the dependency on mosquitto, domoticz depends on
 # !BR2_STATIC_LIBS so set USE_STATIC_BOOST and USE_OPENSSL_STATIC to OFF
 DOMOTICZ_CONF_OPTS += \