package/localedef: depend host build on python3
authorMichael Nosthoff <buildroot@heine.tech>
Mon, 14 Sep 2020 09:47:04 +0000 (11:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 14 Sep 2020 19:11:00 +0000 (21:11 +0200)
Just like glibc, host-localedef needs python3 on the host to
build... since host-localedef is basically using the sources of glibc.

Fixes:

checking if /build/build/per-package/host-localedef/host/bin/ccache
/usr/bin/gcc is sufficient to build libc... yes
checking for x86_64-pc-linux-gnu-nm... /usr/bin/nm
checking for python3... no
checking for python... python
checking version of python... 2.7.18, bad
configure: error:
*** These critical programs are missing or too old: python
*** Check the INSTALL file for required versions.

As reported at:

  http://lists.busybox.net/pipermail/buildroot/2020-September/291929.html

Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/localedef/localedef.mk

index e3c571241c48681605c9e654a8cb89decff38ee2..8eefb84a29407ec075440b1d9f2a435537a1c2e4 100644 (file)
@@ -14,6 +14,7 @@ HOST_LOCALEDEF_DL_SUBDIR = glibc
 
 HOST_LOCALEDEF_DEPENDENCIES = \
        $(BR2_MAKE_HOST_DEPENDENCY) \
+       $(BR2_PYTHON3_HOST_DEPENDENCY) \
        host-bison \
        host-gawk