bind: disable libjson support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 30 Dec 2015 16:51:04 +0000 (13:51 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Dec 2015 18:22:51 +0000 (19:22 +0100)
It conflicts with jsoncpp, bind probes for json/json.h first, but that
header is installed by jsoncpp, which is completely different from
json-c.
Since it's not clear who's correct here (there might be some other
json-c predecessor/version that installs there as well) and the same
functionality (stats channel) is provided by libxml2 as well, just
disable libjson support completely.

Fixes:
http://autobuild.buildroot.net/results/226/2262c9b46663ea7a45e128a5fd7ff30417c2c2a7/build-end.log
(indirectly, it was probing aboslute directories while searching for it)

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bind/bind.mk

index 5a77d82b808bc5ad9529b6692c2996814e53997b..2a065994af3267168ece6d21c865c3e430d21b17 100644 (file)
@@ -22,6 +22,7 @@ BIND_CONF_ENV = \
        BUILD_CC="$(TARGET_CC)" \
        BUILD_CFLAGS="$(TARGET_CFLAGS)"
 BIND_CONF_OPTS = \
+       --with-libjson=no \
        --with-randomdev=/dev/urandom \
        --enable-epoll \
        --with-libtool \
@@ -36,13 +37,6 @@ else
 BIND_CONF_OPTS += --disable-linux-caps
 endif
 
-ifeq ($(BR2_PACKAGE_JSON_C),y)
-BIND_CONF_OPTS += --with-libjson=yes
-BIND_DEPENDENCIES += json-c
-else
-BIND_CONF_OPTS += --with-libjson=no
-endif
-
 ifeq ($(BR2_PACKAGE_LIBXML2),y)
 BIND_CONF_OPTS += --with-libxml2=$(STAGING_DIR)/usr --enable-newstats
 BIND_DEPENDENCIES += libxml2