package/kodi-pvr-nextpvr: bump version to 8.2.1-Matrix
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 2 Mar 2021 07:07:18 +0000 (08:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 6 Mar 2021 21:56:48 +0000 (22:56 +0100)
Switch dependency to kodi after upstream removed the dependency to
kodi-platform:
https://github.com/kodi-pvr/pvr.nextpvr/commit/98b78cee615f5efeb207583c8b75adbaa742e43c
https://github.com/kodi-pvr/pvr.nextpvr/commit/304b0ba94fc2ffb5f2982e6ea4c31cd0e601a44e

Added dependency to tinyxml2:
https://github.com/kodi-pvr/pvr.nextpvr/commit/6855f12ad8496760fa0787660b2c8025ce77311a

Switch license file to LICENSE.md.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/kodi-pvr-nextpvr/Config.in
package/kodi-pvr-nextpvr/kodi-pvr-nextpvr.hash
package/kodi-pvr-nextpvr/kodi-pvr-nextpvr.mk

index e520426796b9c91a2ac9041da1a8d19123f1d836..d260df833fd2032941f338646e9f0c639df810a7 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_KODI_PVR_NEXTPVR
        bool "kodi-pvr-nextpvr"
-       select BR2_PACKAGE_KODI_PLATFORM
+       select BR2_PACKAGE_TINYXML2
        help
          Kodi's NextPVR client addon
 
index 345ece6df9ba7498f0b6a7bcb266aebb862af009..f8d9e6c85316764648c6ded426e0e6a02786ceff 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256  1f5576070a0bf076d1f28cdd547bc4ff134861c18a71cff7fd036eaacc357707  kodi-pvr-nextpvr-3.3.21-Leia.tar.gz
-sha256  0bd576badce05c6b4315c415dabd77d80c871e72026c399f7a7bb8582e0911fe  debian/copyright
+sha256  ebe2b1f96b49c08c5960a6f75da6cb3cfc0cc30d6fafe43b77d2f2249915b752  kodi-pvr-nextpvr-8.2.1-Matrix.tar.gz
+sha256  310782e1abd43c4de6217c513e328bddf999d39302d67c6e05b10a59959827af  LICENSE.md
index b35216048c6adcd8b6cf219f041261ebad5eaaf4..bed6097c8a82fceaee840118ebb4285bcc76dbec 100644 (file)
@@ -4,10 +4,10 @@
 #
 ################################################################################
 
-KODI_PVR_NEXTPVR_VERSION = 3.3.21-Leia
+KODI_PVR_NEXTPVR_VERSION = 8.2.1-Matrix
 KODI_PVR_NEXTPVR_SITE = $(call github,kodi-pvr,pvr.nextpvr,$(KODI_PVR_NEXTPVR_VERSION))
 KODI_PVR_NEXTPVR_LICENSE = GPL-2.0+
-KODI_PVR_NEXTPVR_LICENSE_FILES = debian/copyright
-KODI_PVR_NEXTPVR_DEPENDENCIES = kodi-platform
+KODI_PVR_NEXTPVR_LICENSE_FILES = LICENSE.md
+KODI_PVR_NEXTPVR_DEPENDENCIES = kodi tinyxml2
 
 $(eval $(cmake-package))