scancpan: adjust package name
authorFrancois Perrad <fperrad@gmail.com>
Thu, 23 Jul 2015 16:47:16 +0000 (18:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Jul 2015 20:36:18 +0000 (22:36 +0200)
underscore is not allowed in BR package name.
this problem was found with the Perl module DB_File
which must give the BR package perl-db-file.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/perl-db-file/Config.in
package/perl-db-file/perl-db-file.mk
support/scripts/scancpan

index 18daec304897d9347f510e87fba05429da8088dd..37bc5da25080beb1fc94399bf51d564f1b7e2937 100644 (file)
@@ -8,5 +8,5 @@ config BR2_PACKAGE_PERL_DB_FILE
 
          https://metacpan.org/release/DB_File
 
-comment "perl-db_file needs a toolchain w/ dynamic library"
+comment "perl-db-file needs a toolchain w/ dynamic library"
        depends on BR2_STATIC_LIBS
index 150192622e57bb236ad9ef5a6a0cc52ebde5ab65..46b87ae6ea9e4c7bda2a24fbbbad776acb1dc48e 100644 (file)
@@ -1,6 +1,6 @@
 ################################################################################
 #
-# perl-db_file
+# perl-db-file
 #
 ################################################################################
 
index d2e0563094da302440d25ce826c18b2efbddb499..c7180c8b4df465ed8afa0a57e53e5a49197f2c72 100755 (executable)
@@ -607,6 +607,7 @@ say scalar keys %dist, q{ packages fetched.} unless $quiet;
 # Buildroot package name: lowercase
 sub fsname {
     my $name = shift;
+    $name =~ s|_|-|g;
     return q{perl-} . lc $name;
 }