rsync: use system zlib and popt, also do not lose debug options
authorDenis Mingulov <denis@mingulov.com>
Wed, 16 Oct 2013 13:13:37 +0000 (16:13 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Nov 2013 16:12:51 +0000 (17:12 +0100)
rsync by default compiles statically its own zlib and popt
libraries, it is better to use system wide libraries instead -
both for disk and memory consumption. Change rsync package
accordingly.

Also previously a debug configure option has been lost, as
overwritten by '--with-included-popt' option - fixed.

For example, on ARMv5 rsync binary size is reduced by about 25%.

Signed-off-by: Denis Mingulov <denis@mingulov.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rsync/Config.in
package/rsync/rsync.mk

index be95a7cacd4c2e6bf81ce8216b875fd8401d26f8..b952974efbcbd177c1bad7098a6972acd95a8aa6 100644 (file)
@@ -2,6 +2,8 @@ config BR2_PACKAGE_RSYNC
        bool "rsync"
        # fork()
        depends on BR2_USE_MMU
+       select BR2_PACKAGE_ZLIB
+       select BR2_PACKAGE_POPT
        help
          File transfer program to keep remote files in sync.
 
index d8e5f3f394e81d7cf4870e1c9bae9cdbee7b54ad..35f128c97e592a2ffa71564f599d6181d29a20ef 100644 (file)
@@ -8,7 +8,10 @@ RSYNC_VERSION = 3.1.0
 RSYNC_SITE = http://rsync.samba.org/ftp/rsync/src
 RSYNC_LICENSE = GPLv3+
 RSYNC_LICENSE_FILES = COPYING
-RSYNC_CONF_OPT = $(if $(BR2_ENABLE_DEBUG),--enable-debug,--disable-debug)
-RSYNC_CONF_OPT = --with-included-popt
+RSYNC_DEPENDENCIES = zlib popt
+RSYNC_CONF_OPT = \
+       $(if $(BR2_ENABLE_DEBUG),--enable-debug,--disable-debug) \
+       --with-included-zlib=no \
+       --with-included-popt=no
 
 $(eval $(autotools-package))