toolchain-external: fix uClibc-ng 64bit dynamic loader link
authorBaruch Siach <baruch@tkos.co.il>
Thu, 16 Jul 2015 08:25:34 +0000 (11:25 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 16 Jul 2015 21:12:06 +0000 (23:12 +0200)
Commit 34f95bf9dbb0 (toolchain-external: fix support of uClibc-ng toolchains,
2015-07-13) added the missing ld-uClibc.so.1 dynamic linker symlink that
binaries expect when linked with uClibc-ng. However on 64bit targets the
linker is called ld64-uClibc.so.1. Handle that case as well.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/toolchain-external.mk

index fcb033ca2ebfa082c4c9a891f49502835a904a14..ce9d79f2fa41c19c0f38735b91f70614918d4712 100644 (file)
@@ -730,6 +730,9 @@ define TOOLCHAIN_EXTERNAL_FIXUP_UCLIBCNG_LDSO
        if test -e $(TARGET_DIR)/lib/ld-uClibc.so.1; then \
                ln -sf ld-uClibc.so.1 $(TARGET_DIR)/lib/ld-uClibc.so.0 ; \
        fi
+       if test -e $(TARGET_DIR)/lib/ld64-uClibc.so.1; then \
+               ln -sf ld64-uClibc.so.1 $(TARGET_DIR)/lib/ld64-uClibc.so.0 ; \
+       fi
 endef
 
 define TOOLCHAIN_EXTERNAL_INSTALL_STAGING_CMDS