package/mpv: add optional support for DRM/EGL-based vaapi acceleration
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 18 Jun 2021 19:22:37 +0000 (21:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 18 Jul 2021 21:33:06 +0000 (23:33 +0200)
https://github.com/mpv-player/mpv/blob/master/wscript#L647

Runtime-tested using mesa3d iris driver on a non-x11 system.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpv/Config.in
package/mpv/mpv.mk

index 812491e3a9ea3019bdced7005b8a93b82f9cc6e4..81b1e24b5f0d21aa7c01e99c827ac8b1d166ba8a 100644 (file)
@@ -1,3 +1,9 @@
+config BR2_PACKAGE_MPV_SUPPORTS_VAAPI
+       bool
+       default y if BR2_PACKAGE_LIBDRM && BR2_PACKAGE_MESA3D_OPENGL_EGL
+       default y if BR2_PACKAGE_WAYLAND
+       default y if BR2_PACKAGE_XORG7
+
 config BR2_PACKAGE_MPV
        bool "mpv"
        depends on BR2_INSTALL_LIBSTDCPP # libass
index 4292abb876d12d904c381dfe8cf4c66758a16fb8..d4d4d4811d36c9b3f5fffe4dcd773dc2782658e5 100644 (file)
@@ -178,17 +178,16 @@ MPV_CONF_OPTS += --disable-rpi
 endif
 
 # va-api support
-# This requires one or more of the egl-drm, wayland, x11 backends
-# For now we support wayland and x11
-ifeq ($(BR2_PACKAGE_LIBVA),y)
-ifneq ($(BR2_PACKAGE_WAYLAND)$(BR2_PACKAGE_XORG7),)
+ifeq ($(BR2_PACKAGE_LIBVA)$(BR2_PACKAGE_MPV_SUPPORTS_VAAPI),yy)
 MPV_CONF_OPTS += --enable-vaapi
 MPV_DEPENDENCIES += libva
+ifeq ($(BR2_PACKAGE_LIBDRM),y)
+MPV_CONF_OPTS += --enable-vaapi-drm
 else
-MPV_CONF_OPTS += --disable-vaapi
+MPV_CONF_OPTS += --disable-vaapi-drm
 endif
 else
-MPV_CONF_OPTS += --disable-vaapi
+MPV_CONF_OPTS += --disable-vaapi --disable-vaapi-drm
 endif
 
 # wayland support