postgresql: enable bfin compile
authorPeter Seiderer <ps.report@gmx.net>
Tue, 10 Mar 2015 19:59:39 +0000 (20:59 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 16 Mar 2015 21:02:37 +0000 (22:02 +0100)
- overwrite platform support with linux template
- disable spinlock support

[Thomas: use the --with-template=linux option unconditionally.]

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/postgresql/postgresql.mk

index 7dc3f0bf029e54d0688f80303388e10d80a8b290..d426093a30cd037ea4aa809be608be42680c5a9f 100644 (file)
@@ -13,6 +13,11 @@ POSTGRESQL_LICENSE_FILES = COPYRIGHT
 POSTGRESQL_INSTALL_STAGING = YES
 POSTGRESQL_CONFIG_SCRIPTS = pg_config
 
+# In most cases, postgresql configure script is able to guess the
+# platform, except for noMMU platforms that use the 'uclinux' host
+# qualifier, as is the case on Blackfin
+POSTGRESQL_CONF_OPTS = --with-template=linux
+
 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
 # overwrite IPV6 detection
 ifeq ($(BR2_INET_IPV6),y)
@@ -31,7 +36,7 @@ ifneq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
        POSTGRESQL_CONF_OPTS += --disable-thread-safety
 endif
 
-ifeq ($(BR2_microblazeel)$(BR2_microblazebe)$(BR2_nios2)$(BR2_xtensa),y)
+ifeq ($(BR2_bfin)$(BR2_microblazeel)$(BR2_microblazebe)$(BR2_nios2)$(BR2_xtensa),y)
        POSTGRESQL_CONF_OPTS += --disable-spinlocks
 endif