spice: bump to version 0.12.5
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 21 Jun 2017 22:07:41 +0000 (00:07 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 22 Jun 2017 21:25:18 +0000 (23:25 +0200)
Tunneling support is gone upstream, so drop the patch and add
Config.in.legacy handling for the option.

Celt051 is no longer a hard dependency, and opus is a new optional
dependency, so adjust the dependencies to match.

Python / pyparsing are not needed as the tarball contains the generated
files (this should presumably have been host-python in the first place as
these are used at build time), but we need a small workaround to convince
configure that they really aren't needed.

Alsa-lib is only needed for client support, and the configure script checks
for X11/Xext/Xrender, so adjust the dependencies to match.

A user manual is now generated by default if asciidoc is available, so
explicitly disable that.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/spice/0001-fix-missing-monitor_latency-argument.patch [deleted file]
package/spice/Config.in
package/spice/spice.hash
package/spice/spice.mk

index 9a534956270db7d8f939299a99e0ae6597be5089..dc99b7c2eb523c054c2d363ead022019e49866bf 100644 (file)
@@ -145,6 +145,13 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2017.08"
 
+config BR2_PACKAGE_SPICE_TUNNEL
+       bool "spice network redirection removed"
+       select BR2_LEGACY
+       help
+         Spice network redirection, aka tunnelling has been removed
+         upstream.
+
 config BR2_PACKAGE_INPUT_TOOLS
        bool "input-tools removed"
        select BR2_LEGACY
diff --git a/package/spice/0001-fix-missing-monitor_latency-argument.patch b/package/spice/0001-fix-missing-monitor_latency-argument.patch
deleted file mode 100644 (file)
index e14dd2c..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From 0d3767853ca179ce04a9b312d7a30d33d1266a3b Mon Sep 17 00:00:00 2001
-From: Axel Lin <axel.lin@ingics.com>
-Date: Thu, 10 Oct 2013 12:36:40 +0800
-Subject: [PATCH] red_tunnel_worker: Fix build error due to missing monitor_latency argument
-
-Fix missing monitor_latency argument in red_channel_client_create call.
-
-Signed-off-by: Axel Lin <axel.lin@ingics.com>
----
- server/red_tunnel_worker.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/server/red_tunnel_worker.c b/server/red_tunnel_worker.c
-index 97dcafd..6781d73 100644
---- a/server/red_tunnel_worker.c
-+++ b/server/red_tunnel_worker.c
-@@ -3417,7 +3417,7 @@ static void handle_tunnel_channel_link(RedChannel *channel, RedClient *client,
-     }
-     tcc = (TunnelChannelClient*)red_channel_client_create(sizeof(TunnelChannelClient),
--                                                          channel, client, stream,
-+                                                          channel, client, stream, FALSE,
-                                                           0, NULL, 0, NULL);
-     if (!tcc) {
-         return;
--- 
-1.8.1.2
-
index bde3a92859bbffd1840108ed525d34eae6b3c543..220f9994dad7d161d93d5531530ca0250c2b6c30 100644 (file)
@@ -2,23 +2,15 @@ comment "spice server needs a toolchain w/ wchar, threads"
        depends on BR2_i386 || BR2_x86_64
        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
 
-comment "spice server depends on python (for pyparsing)"
-       depends on BR2_i386 || BR2_x86_64
-       depends on !BR2_PACKAGE_PYTHON
-
 config BR2_PACKAGE_SPICE
        bool "spice server"
        depends on BR2_i386 || BR2_x86_64
-       depends on BR2_PACKAGE_PYTHON
        depends on BR2_USE_WCHAR # libglib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
-       select BR2_PACKAGE_ALSA_LIB
-       select BR2_PACKAGE_CELT051
        select BR2_PACKAGE_JPEG
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_OPENSSL
        select BR2_PACKAGE_PIXMAN
-       select BR2_PACKAGE_PYTHON_PYPARSING
        select BR2_PACKAGE_SPICE_PROTOCOL
        help
          The Spice project aims to provide a complete open source
@@ -43,6 +35,10 @@ config BR2_PACKAGE_SPICE_CLIENT
        depends on BR2_INSTALL_LIBSTDCPP
        select BR2_PACKAGE_XLIB_LIBXFIXES
        select BR2_PACKAGE_XLIB_LIBXRANDR
+       select BR2_PACKAGE_XLIB_LIBX11
+       select BR2_PACKAGE_XLIB_LIBXEXT
+       select BR2_PACKAGE_XLIB_LIBXRENDER
+       select BR2_PACKAGE_ALSA_LIB
 
 comment "client needs a toolchain w/ threads, C++"
        depends on BR2_PACKAGE_XORG7
@@ -60,11 +56,4 @@ config BR2_PACKAGE_SPICE_GUI
 comment "gui needs a toolchain w/ dynamic library"
        depends on BR2_STATIC_LIBS
 
-config BR2_PACKAGE_SPICE_TUNNEL
-       bool "Enable network redirection"
-       select BR2_PACKAGE_SLIRP
-       help
-         Say 'y' here to enable network redirection, aka tunnelling
-         through a SLIP/SLIRP session.
-
 endif # BR2_PACKAGE_SPICE
index c4d63198fb0ac447f3f6e930dc27428117c7f70e..0a943f033282cbd7846ea19888e103b5f93800fd 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 cf063e7df42e331a835529d2f613d8a01f8cb2963e8edaadf73a8d65c46fb387        spice-0.12.4.tar.bz2
+sha256 4209a20d8f67cb99a8a6ac499cfe79a18d4ca226360457954a223d6795c2f581        spice-0.12.5.tar.bz2
index 1d26ddcc184ca9928aa96bee6d0edba629f214fc..ba76a14d610473eb08a1a090417b3ad95fb1349b 100644 (file)
@@ -4,20 +4,17 @@
 #
 ################################################################################
 
-SPICE_VERSION = 0.12.4
+SPICE_VERSION = 0.12.5
 SPICE_SOURCE = spice-$(SPICE_VERSION).tar.bz2
 SPICE_SITE = http://www.spice-space.org/download/releases
 SPICE_LICENSE = LGPL-2.1+
 SPICE_LICENSE_FILES = COPYING
 SPICE_INSTALL_STAGING = YES
 SPICE_DEPENDENCIES = \
-       alsa-lib \
-       celt051 \
        jpeg \
        libglib2 \
        openssl \
        pixman \
-       python-pyparsing \
        spice-protocol
 
 # We disable everything for now, because the dependency tree can become
@@ -26,13 +23,32 @@ SPICE_CONF_OPTS = \
        --disable-opengl \
        --disable-smartcard \
        --disable-automated-tests \
-       --without-sasl
+       --without-sasl \
+       --disable-manual
 
 SPICE_DEPENDENCIES += host-pkgconf
 
+ifeq ($(BR2_PACKAGE_CELT051),y)
+SPICE_CONF_OPTS += --enable-celt051
+SPICE_DEPENDENCIES += celt051
+else
+SPICE_CONF_OPTS += --disable-celt051
+endif
+
+# no enable/disable, detected using pkg-config
+ifeq ($(BR2_PACKAGE_OPUS),y)
+SPICE_DEPENDENCIES += opus
+endif
+
 ifeq ($(BR2_PACKAGE_SPICE_CLIENT),y)
 SPICE_CONF_OPTS += --enable-client
-SPICE_DEPENDENCIES += xlib_libXfixes xlib_libXrandr
+SPICE_DEPENDENCIES += \
+       xlib_libXfixes \
+       xlib_libXrandr \
+       xlib_libX11 \
+       xlib_libXext \
+       xlib_libXrender \
+       alsa-lib
 else
 SPICE_CONF_OPTS += --disable-client
 endif
@@ -44,15 +60,16 @@ else
 SPICE_CONF_OPTS += --disable-gui
 endif
 
-ifeq ($(BR2_PACKAGE_SPICE_TUNNEL),y)
-SPICE_CONF_OPTS += --enable-tunnel
-SPICE_DEPENDENCIES += slirp
-else
-SPICE_CONF_OPTS += --disable-tunnel
-endif
+# spice uses a number of source files that are generated with python / pyparsing.
+# The generated files are part of the tarball, so python / pyparsing isn't needed
+# when building from the tarball, but the configure script gets confused and looks
+# for the wrong file name to know if it needs to check for python / pyparsing,
+# so convince it they aren't needed
+define SPICE_NO_PYTHON_PYPARSING
+       touch $(@D)/client/generated_marshallers.cpp
+endef
 
-SPICE_CONF_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
-SPICE_MAKE_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
+SPICE_PRE_CONFIGURE_HOOKS += SPICE_NO_PYTHON_PYPARSING
 
 # We need to tweak spice.pc because it /forgets/ (for static linking) that
 # it should link against libz and libjpeg. libz is pkg-config-aware, while