package/tar: add support for acl and xattr
authorMaxim Mikityanskiy <maxtram95@gmail.com>
Mon, 19 Jan 2015 16:14:13 +0000 (18:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 2 Feb 2015 08:25:22 +0000 (09:25 +0100)
If acl or attr is going to be installed, add support for them to tar.

[Thomas: explicitly disable acl and attr support when the
corresponding packages are not available.]

Signed-off-by: Maxim Mikityanskiy <maxtram95@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tar/tar.mk

index caaa5adfb870bd78aca221bddc799879def9750b..2b47e334d5f9985c01846bf3e27b8fe946ac7717 100644 (file)
@@ -19,6 +19,20 @@ TAR_DEPENDENCIES += busybox
 HOST_TAR_DEPENDENCIES =
 endif
 
+ifeq ($(BR2_PACKAGE_ACL),y)
+TAR_DEPENDENCIES += acl
+TAR_CONF_OPTS += --with-posix-acls
+else
+TAR_CONF_OPTS += --without-posix-acls
+endif
+
+ifeq ($(BR2_PACKAGE_ATTR),y)
+TAR_DEPENDENCIES += attr
+TAR_CONF_OPTS += --with-xattrs
+else
+TAR_CONF_OPTS += --without-xattrs
+endif
+
 $(eval $(autotools-package))
 
 # host-tar: use cpio.gz instead of tar.gz to prevent chicken-egg problem