infra: /usr support: STAGING_DIR can be outside BASE_DIR
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Thu, 3 Jul 2014 19:58:43 +0000 (21:58 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 4 Jul 2014 13:49:59 +0000 (15:49 +0200)
If the user sets a custom BR2_HOST_DIR, then STAGING_DIR is not under
BASE_DIR. The .pc/.la file fixup commands incorrectly made this assumption
and thus should be corrected.

Additionally, this patch:
- rewords the comment in pkg-autotools that explains the replacements.
- removes a for statement in favor of xargs

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-autotools.mk
package/pkg-generic.mk
package/qt5/qt5.mk

index 8527314276340a88925011e398069d07b15b5d26..432b27f65726019886715ba98ba82b535593f908 100644 (file)
@@ -267,25 +267,26 @@ endif
 # Most autotools packages install libtool .la files alongside any
 # installed libraries. These .la files sometimes refer to paths
 # relative to the sysroot, which libtool will interpret as absolute
-# paths to host libraries instead of the target libraries. Since we
-# configure with --prefix=/usr, such absolute paths start with
-# /usr. So we add $(STAGING_DIR) in front of any path that starts with
-# /usr.
+# paths to host libraries instead of the target libraries. Since this
+# is not what we want, these paths are fixed by prefixing them with
+# $(STAGING_DIR).  As we configure with --prefix=/usr, this fix
+# needs to be applied to any path that starts with /usr.
 #
-# To protect against the case that the output directory itself is
-# under /usr, we first substitute away any occurences of the output
-# directory to @BASE_DIR@.
+# To protect against the case that the output or staging directories
+# themselves are under /usr, we first substitute away any occurrences
+# of these directories as @BASE_DIR@ and @STAGING_DIR@. Note that
+# STAGING_DIR can be outside BASE_DIR when the user sets BR2_HOST_DIR
+# to a custom value.
 #
 ifndef $(2)_INSTALL_STAGING_CMDS
 define $(2)_INSTALL_STAGING_CMDS
        $$(TARGET_MAKE_ENV) $$($$(PKG)_MAKE_ENV) $$($$(PKG)_MAKE) $$($$(PKG)_INSTALL_STAGING_OPT) -C $$($$(PKG)_SRCDIR)
-       for i in $$$$(find $$(STAGING_DIR)/usr/lib* -name "*.la"); do \
+       find $$(STAGING_DIR)/usr/lib* -name "*.la" | xargs \
                $$(SED) "s:$$(BASE_DIR):@BASE_DIR@:g" \
+                       -e "s:$$(STAGING_DIR):@STAGING_DIR@:g" \
                        -e "s:\(['= ]\)/usr:\\1@STAGING_DIR@/usr:g" \
                        -e "s:@STAGING_DIR@:$$(STAGING_DIR):g" \
-                       -e "s:@BASE_DIR@:$$(BASE_DIR):g" \
-                       $$$$i; \
-       done
+                       -e "s:@BASE_DIR@:$$(BASE_DIR):g"
 endef
 endif
 
index ab1f8d2ca1e21880363d57c3f014ce6c1950e03c..b7f50a538be74c2232ea4ab655216b98715920d8 100644 (file)
@@ -202,6 +202,7 @@ $(BUILD_DIR)/%/.stamp_staging_installed:
        $(Q)if test -n "$($(PKG)_CONFIG_SCRIPTS)" ; then \
                $(call MESSAGE,"Fixing package configuration files") ;\
                        $(SED)  "s,$(BASE_DIR),@BASE_DIR@,g" \
+                               -e "s,$(STAGING_DIR),@STAGING_DIR@,g" \
                                -e "s,^\(exec_\)\?prefix=.*,\1prefix=@STAGING_DIR@/usr,g" \
                                -e "s,-I/usr/,-I@STAGING_DIR@/usr/,g" \
                                -e "s,-L/usr/,-L@STAGING_DIR@/usr/,g" \
index 5f90eb5cc0c37e6d32c68fe90a1706654f7572d7..a88b593fd7615e9644d4e8b0d562b2eee80c026d 100644 (file)
@@ -6,6 +6,7 @@ include $(sort $(wildcard package/qt5/*/*.mk))
 define QT5_LA_PRL_FILES_FIXUP
        for i in $$(find $(STAGING_DIR)/usr/lib* -name "libQt5*.la"); do \
                $(SED)  "s:$(BASE_DIR):@BASE_DIR@:g" \
+                       -e "s:$(STAGING_DIR):@STAGING_DIR@:g" \
                        -e "s:\(['= ]\)/usr:\\1@STAGING_DIR@/usr:g" \
                        -e "s:@STAGING_DIR@:$(STAGING_DIR):g" \
                        -e "s:@BASE_DIR@:$(BASE_DIR):g" \