build log: add message when starting target-finalize target
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Mon, 12 May 2014 14:19:27 +0000 (16:19 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 12 May 2014 20:22:32 +0000 (22:22 +0200)
The target-finalize target does a large number of actions (removing
unnecessary files, stripping objects, etc.) but does not have a header. This
makes it seem that all these actions are done as part of the last action
before target-finalize, for example:
    >>> makedevs undefined Installing to target

To make a clear distinction, add a message to the beginning of
target-finalize:
    >>>   Finalizing target directory

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile

index 2f18aabdb5969398281c227c3b0bfc6f5c31b62a..4b06ab5aed1697506b16717cdde5af5ee2bdb2e4 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -533,6 +533,7 @@ endif
 $(TARGETS_ROOTFS): target-finalize
 
 target-finalize: $(TARGETS)
+       @$(call MESSAGE,"Finalizing target directory")
        $(TARGET_PURGE_LOCALES)
        rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/share/aclocal \
                $(TARGET_DIR)/usr/lib/pkgconfig $(TARGET_DIR)/usr/share/pkgconfig \