glm: Added package
authorPaul Cercueil <paul@crapouillou.net>
Fri, 15 Aug 2014 17:19:38 +0000 (19:19 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 28 Sep 2014 19:33:42 +0000 (21:33 +0200)
OpenGL Mathematics (GLM) is a header only C++ mathematics library for
graphics software based on the OpenGL Shading Language (GLSL)
specification.

http://glm.g-truc.net/

Signed-off-by: Paul Cercueil <paul@crapouillou.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/glm/Config.in [new file with mode: 0644]
package/glm/glm.mk [new file with mode: 0644]

index 2eefc3f7389f1f90df7596320fafde411ff34382..2ad72bccccd09a9fd507405af9a5b8bf7532918b 100644 (file)
@@ -836,6 +836,7 @@ menu "Other"
        source "package/fftw/Config.in"
        source "package/flann/Config.in"
        source "package/glibmm/Config.in"
+       source "package/glm/Config.in"
        source "package/gmp/Config.in"
        source "package/gsl/Config.in"
        source "package/gtest/Config.in"
diff --git a/package/glm/Config.in b/package/glm/Config.in
new file mode 100644 (file)
index 0000000..41b3608
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_GLM
+       bool "glm"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         OpenGL Mathematics (GLM)
+
+         http://glm.g-truc.net
+
+comment "glm needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/glm/glm.mk b/package/glm/glm.mk
new file mode 100644 (file)
index 0000000..ff9423d
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# glm
+#
+################################################################################
+
+GLM_VERSION = 0.9.5.4
+GLM_SITE = $(call github,g-truc,glm,$(GLM_VERSION))
+GLM_LICENSE = MIT
+GLM_LICENSE_FILES = copying.txt
+
+# GLM is a header-only library, it only makes sense
+# to have it installed into the staging directory.
+GLM_INSTALL_STAGING = YES
+GLM_INSTALL_TARGET = NO
+
+$(eval $(cmake-package))