package/gawk: add optional readline dependency
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 6 Dec 2015 11:13:59 +0000 (12:13 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 13 Dec 2015 15:01:20 +0000 (16:01 +0100)
The gawk debugger can optionally use readline for user input during
the debugging session (for the usual autocompletion and stuff).

Enable readline support when the readline package is enabled; let
./configure automatically find it. Forcibly disable readline support
when the readline package is disabled.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Peter Korsgaard <jacmet@uclibc.org>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gawk/gawk.mk

index 0fd131d8526d665ecd525521261ce0f64dce9184..507ea6de6fa5c0879f9da57f7fd5beceeecf3429 100644 (file)
@@ -24,6 +24,14 @@ else
 GAWK_CONF_OPTS += --without-mpfr
 endif
 
+# --with-readline requires an argument so just let
+# configure find it automatically
+ifeq ($(BR2_PACKAGE_READLINE),y)
+GAWK_DEPENDENCIES += readline
+else
+GAWK_CONF_OPTS += --without-readline
+endif
+
 # We don't have a host-busybox, and we don't want to use readline or mpfr
 HOST_GAWK_DEPENDENCIES =