be sure the dir is present
authorEric Andersen <andersen@codepoet.org>
Thu, 6 May 2004 09:09:58 +0000 (09:09 -0000)
committerEric Andersen <andersen@codepoet.org>
Thu, 6 May 2004 09:09:58 +0000 (09:09 -0000)
make/sed.mk

index 71546ca5c42677bded39391c2e14c445c146f0b5..2476c59aad9acbb6e1a5a1ff5481363711410192 100644 (file)
@@ -53,6 +53,7 @@ build-sed-host-binary: $(SED_DIR1)/$(SED_BINARY)
        @if [ ! -f $(STAGING_DIR)/$(SED_TARGET_BINARY) -o $(STAGING_DIR)/$(SED_TARGET_BINARY) \
        -ot $(SED_DIR1)/$(SED_BINARY) ] ; then \
            set -x; \
+           mkdir -p $(STAGING_DIR)/bin; \
            $(MAKE) DESTDIR=$(STAGING_DIR) -C $(SED_DIR1) install; \
            mv $(STAGING_DIR)/usr/bin/sed $(STAGING_DIR)/bin/; \
            rm -rf $(STAGING_DIR)/share/locale $(STAGING_DIR)/usr/info \