package/uacme: bump version to 1.2.2
authorNicola Di Lieto <nicola.dilieto@gmail.com>
Sat, 18 Apr 2020 21:26:17 +0000 (23:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 21 Apr 2020 20:32:56 +0000 (22:32 +0200)
This version includes a new binary named "ualpn", a proxying
ACMEv2 tls-alpn-01 responder.

Signed-off-by: Nicola Di Lieto <nicola.dilieto@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/uacme/Config.in
package/uacme/uacme.hash
package/uacme/uacme.mk

index ea9babfda7860a5daccabd34e5726d0cba3230e4..58b7c534e73d147d89b1cc82f8a7141247c8ed62 100644 (file)
@@ -5,7 +5,7 @@ config BR2_PACKAGE_UACME
        select BR2_PACKAGE_LIBCURL
        help
          uacme is a client for the ACMEv2 protocol described in
-         RFC8555, written in plain C code with minimal dependencies
+         RFC8555, written in plain C with minimal dependencies
          (libcurl and either of GnuTLS, OpenSSL or mbedTLS). The
          ACMEv2 protocol allows a Certificate Authority
          (https://letsencrypt.org is a popular one) and an applicant
@@ -13,3 +13,18 @@ config BR2_PACKAGE_UACME
          issuance.
 
          https://github.com/ndilieto/uacme
+
+if BR2_PACKAGE_UACME
+
+config BR2_PACKAGE_UACME_UALPN
+       bool "enable ualpn"
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_PACKAGE_LIBEV
+       help
+         Build and install ualpn, the transparent proxying tls-alpn-01
+         challenge responder.
+
+comment "ualpn needs a toolchain w/ threads"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
+
+endif
index 5c68680b548a96fea247ce431ffa1764ebc3bea1..abc30a7e545d397113d55b84d398d05c7a9acc7e 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed:
-sha256 08070779232c9711a227189ee2d3cb55042f6be2ea0aa59525cb7b554c4688b0        uacme-1.0.22.tar.gz
+sha256 26fa153118fc895f0961502d644e3606cccb7fb261594c2b7dd293decd0b0174        uacme-1.2.2.tar.gz
 sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903        COPYING
index c5931e268231c85f44f4e7adb2996587f394bdd3..61d3f11ca1108685f9b7b6f1d1b29338a3b49d02 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-UACME_VERSION = 1.0.22
+UACME_VERSION = 1.2.2
 # Released versions are on branch upstream/latest, tagged as
 # upstream/X.Y.Z Do not use vX.Y.Z tags from master, as they do not
 # include .tarball-version
@@ -26,4 +26,11 @@ UACME_CONF_OPTS += --with-openssl
 UACME_DEPENDENCIES += openssl
 endif
 
+ifeq ($(BR2_PACKAGE_UACME_UALPN),y)
+UACME_DEPENDENCIES += libev
+UACME_CONF_OPTS += --with-ualpn
+else
+UACME_CONF_OPTS += --without-ualpn
+endif
+
 $(eval $(autotools-package))