package/gstreamer1: Allow to build OpenJPEG plugin
authorVincent Dehors <vincent.dehors@openwide.fr>
Wed, 30 Dec 2015 15:26:45 +0000 (16:26 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 30 Dec 2015 20:06:38 +0000 (21:06 +0100)
The OpenJPEG library is packaged in buildroot (version 1) and there is a
plugin "openjpeg" using it in gst1-plugins-bad. This commit add the option
for building this plugin. It provide a JPEG2000 encoder and decoder.

[Peter: use 'select' instead of 'depends on', sort alphabetically]
Signed-off-by: Vincent Dehors <vincent.dehors@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index a834f139a6e1908eb2fbbafe401b4d4d84fdb00e..bc9415baa04a0305f61d9642b472ced413efad82 100644 (file)
@@ -597,6 +597,12 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_OPENH264
        bool "openh264"
        select BR2_PACKAGE_LIBOPENH264
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_OPENJPEG
+       bool "openjpeg"
+       select BR2_PACKAGE_OPENJPEG
+       help
+         GStreamer OpenJPEG plugin
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_OPUS
        bool "opus"
        select BR2_PACKAGE_OPUS
index 64760a8c454abce3a74408cb6d4fbee4b51c3b2f..5a913a32190482691066527a12fb46439341eec7 100644 (file)
@@ -58,7 +58,6 @@ GST1_PLUGINS_BAD_CONF_OPTS += \
        --disable-nas \
        --disable-ofa \
        --disable-openexr \
-       --disable-openjpeg \
        --disable-openni2 \
        --disable-pvr \
        --disable-libvisual \
@@ -715,6 +714,13 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-opencv
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_OPENJPEG),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-openjpeg
+GST1_PLUGINS_BAD_DEPENDENCIES += openjpeg
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-openjpeg
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_OPUS),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-opus
 GST1_PLUGINS_BAD_DEPENDENCIES += opus