package: add python-websocket-client
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 9 Mar 2018 19:16:53 +0000 (20:16 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 10 Mar 2018 07:30:16 +0000 (08:30 +0100)
WebSocket client module for python.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
DEVELOPERS
package/Config.in
package/python-websocket-client/Config.in [new file with mode: 0644]
package/python-websocket-client/python-websocket-client.hash [new file with mode: 0644]
package/python-websocket-client/python-websocket-client.mk [new file with mode: 0644]

index 845aece54eff29613808f85f31bfc3711aa46dd4..c13bb448f54b44ba1ec8b90cc96a9c3f10d3c4dd 100644 (file)
@@ -1391,6 +1391,7 @@ F:        package/python-enum34/
 F:     package/python-ipaddr/
 F:     package/python-pam/
 F:     package/python-psutil/
+F:     package/python-websocket-client/
 F:     package/triggerhappy/
 
 N:     Peter Seiderer <ps.report@gmx.net>
index a5604fc36b71f661e76939319d1071732e165162..9c727cad6c23b9436a17c05aec2cb18d0870a3a1 100644 (file)
@@ -949,6 +949,7 @@ menu "External python modules"
        source "package/python-wcwidth/Config.in"
        source "package/python-web2py/Config.in"
        source "package/python-webpy/Config.in"
+       source "package/python-websocket-client/Config.in"
        source "package/python-websockets/Config.in"
        source "package/python-werkzeug/Config.in"
        source "package/python-whoosh/Config.in"
diff --git a/package/python-websocket-client/Config.in b/package/python-websocket-client/Config.in
new file mode 100644 (file)
index 0000000..0fbb15b
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_WEBSOCKET_CLIENT
+       bool "python-websocket-client"
+       select BR2_PACKAGE_PYTHON_SIX # runtime
+       select BR2_PACKAGE_PYTHON_SSL if BR2_PACKAGE_PYTHON # runtime
+       select BR2_PACKAGE_PYTHON3_SSL if BR2_PACKAGE_PYTHON3 # runtime
+       help
+         WebSocket client for python. hybi13 is supported.
+
+         https://github.com/websocket-client/websocket-client.git
diff --git a/package/python-websocket-client/python-websocket-client.hash b/package/python-websocket-client/python-websocket-client.hash
new file mode 100644 (file)
index 0000000..3672ca0
--- /dev/null
@@ -0,0 +1,4 @@
+# md5 from https://pypi.python.org/pypi/websocket-client/json, sha256 locally computed
+md5    790b3ecb5364293ad70c59a1b92debb1  websocket_client-0.47.0.tar.gz
+sha256 a453dc4dfa6e0db3d8fd7738a308a88effe6240c59f3226eb93e8f020c216149  websocket_client-0.47.0.tar.gz
+sha256 e580b2a1a57c33085dd6a07cff693d828f7c3fa8a11ce56ade2a62c46951930d  LICENSE
diff --git a/package/python-websocket-client/python-websocket-client.mk b/package/python-websocket-client/python-websocket-client.mk
new file mode 100644 (file)
index 0000000..58c8407
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-websocket-client
+#
+################################################################################
+
+PYTHON_WEBSOCKET_CLIENT_VERSION = 0.47.0
+PYTHON_WEBSOCKET_CLIENT_SOURCE = websocket_client-$(PYTHON_WEBSOCKET_CLIENT_VERSION).tar.gz
+PYTHON_WEBSOCKET_CLIENT_SITE = https://pypi.python.org/packages/c9/bb/8d3dd9063cfe0cd5d03fe6a1f74ddd948f384e9c1eff0eb978f3976a7d27
+PYTHON_WEBSOCKET_CLIENT_SETUP_TYPE = setuptools
+PYTHON_WEBSOCKET_CLIENT_LICENSE = LGPL-2.1+
+PYTHON_WEBSOCKET_CLIENT_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))