package/vlc: express the dependency on freerdp
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 4 Mar 2015 22:15:33 +0000 (23:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 4 Mar 2015 22:23:34 +0000 (23:23 +0100)
vlc can use the freerdp library if present.

This is currently a hidden dependency, as we do not express it in our
vlc.mk rules. Package ordering makes it so that freerdp is built before
vlc; however, manually building vlc (with 'make vlc') would miss the
dependency because of that package ordering.

Explcitly add freerdp (if enabled) as a dependency of vlc to ensure
build order in every cases.

Reported-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vlc/vlc.mk

index 56006b5b460cfe5174497b41047493409edcc420..1499f8bf2f8610c2e6315812a4346d9763a2a1ce 100644 (file)
@@ -117,6 +117,13 @@ else
 VLC_CONF_OPTS += --disable-flac
 endif
 
+ifeq ($(BR2_PACKAGE_FREERDP),y)
+VLC_CONF_OPTS += --enable-libfreerdp
+VLC_DEPENDENCIES += freerdp
+else
+VLC_CONF_OPTS += --disable-libfreerdp
+endif
+
 ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)
 VLC_CONF_OPTS += --enable-glx
 VLC_DEPENDENCIES += libgl