gptfdisk: fix static linking issue with iconv
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 22 May 2015 12:49:32 +0000 (14:49 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 22 May 2015 12:49:32 +0000 (14:49 +0200)
Fixes:
http://autobuild.buildroot.net/results/e89/e891a5bab72690a530781ad87d5804a53a209b5c/

Similar to libintl, some of the gptfdisk dependencies may link against
libiconv, so we need to do so as well when linking statically.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gptfdisk/gptfdisk.mk

index c11b1d9cd4041f26381ce6dc0f8a23cea086e005..e84e3d39e8ff0933c0e9c22b1f4fd8e78d997fd9 100644 (file)
@@ -21,13 +21,17 @@ ifeq ($(BR2_PACKAGE_GPTFDISK_CGDISK),y)
 GPTFDISK_DEPENDENCIES += ncurses
 endif
 
-ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE)$(BR2_STATIC_LIBS),yy)
-GPTFDISK_MAKE_OPTS += LDLIBS=-lintl
+ifeq ($(BR2_STATIC_LIBS),y)
+# gptfdisk dependencies may link against libintl/libiconv, so we need
+# to do so as well when linking statically
+GPTFDISK_LDLIBS = \
+       $(if $(BR2_PACKAGE_GETTEXT),-lintl) \
+       $(if $(BR2_PACKAGE_LIBICONV),-liconv)
 endif
 
 define GPTFDISK_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
-               $(GPTFDISK_MAKE_OPTS) $(GPTFDISK_TARGETS_y)
+               LDLIBS='$(GPTFDISK_LDLIBS)' $(GPTFDISK_TARGETS_y)
 endef
 
 define GPTFDISK_INSTALL_TARGET_CMDS