package/brltty: add pcre optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 28 Sep 2019 12:08:35 +0000 (14:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 28 Sep 2019 20:46:30 +0000 (22:46 +0200)
pcre/pcre2 has been added in version 6.0 with:
- https://github.com/brltty/brltty/commit/579cae458ad9e47a689c7063e600d7bc492cb176
- https://github.com/brltty/brltty/commit/e7f36c00dbfb2030ad67b9b7e159c6d847f1d7d9

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/brltty/brltty.mk

index aee18d0b9acd0f81c1d0349582094feb490b9359..b9d608b9f52ac17c040e68019f77f1490756f8e4 100644 (file)
@@ -78,6 +78,16 @@ else
 BRLTTY_CONF_OPTS += --without-curses
 endif
 
+ifeq ($(BR2_PACKAGE_PCRE2_32),y)
+BRLTTY_DEPENDENCIES += pcre2
+BRLTTY_CONF_OPTS += --with-rgx-package
+else ifeq ($(BR2_PACKAGE_PCRE_32),y)
+BRLTTY_DEPENDENCIES += pcre
+BRLTTY_CONF_OPTS += --with-rgx-package
+else
+BRLTTY_CONF_OPTS += --without-rgx-package
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD),y)
 BRLTTY_DEPENDENCIES += systemd
 BRLTTY_CONF_OPTS += --with-service-package