projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1359943
)
pulseaudio: correct libgtk3 handling
author
Peter Korsgaard
<peter@korsgaard.com>
Sun, 26 Oct 2014 02:03:20 +0000
(
03:03
+0100)
committer
Peter Korsgaard
<peter@korsgaard.com>
Sun, 26 Oct 2014 02:03:20 +0000
(
03:03
+0100)
The gtk3 support uses X11 specific functionality, so it should only be
enabled if the X11 backend is enabled.
Fixes:
http://autobuild.buildroot.net/results/9d9/
9d9ddea26a5193367a80eede1be1122cec5cd939
/
http://autobuild.buildroot.net/results/3fb/
3fbbdbf39e29319b349b2cf155397a121f24bf28
/
http://autobuild.buildroot.net/results/ccf/
ccf31740a0e730f2626db9051931b1e0703c770d
/
And many others.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pulseaudio/pulseaudio.mk
patch
|
blob
|
history
diff --git
a/package/pulseaudio/pulseaudio.mk
b/package/pulseaudio/pulseaudio.mk
index 8d3d0f765f767c08520f36fbdf424299c9867187..d24dcc8f2eb809eaa1618ae36f6f993579d4db49 100644
(file)
--- a/
package/pulseaudio/pulseaudio.mk
+++ b/
package/pulseaudio/pulseaudio.mk
@@
-47,6
+47,14
@@
else
PULSEAUDIO_CONF_OPTS += --without-caps
endif
+# gtk3 support needs X11 backend
+ifeq ($(BR2_PACKAGE_LIBGTK3_X11),y)
+PULSEAUDIO_DEPENDENCIES += libgtk3
+PULSEAUDIO_CONF_OPTS += --enable-gtk3
+else
+PULSEAUDIO_CONF_OPTS += --disable-gtk3
+endif
+
ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
# The optional webrtc echo canceller is written in C++, causing auto* to want
# to link module-echo-cancel.so with CXX even if webrtc ISN'T used.