package/linux-firmware: add option for TI CC2560(A) Bluetooth module
authorDavid Lechner <david@lechnology.com>
Thu, 27 Dec 2018 19:53:03 +0000 (13:53 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 28 Dec 2018 10:47:59 +0000 (11:47 +0100)
This adds a new config option to include the firmware files for the TI
CC2560 and CC2560A Bluetooth modules. LEGO MINDSTORMS EV3 has one of
these two modules depending on when it was manufactured, so it is
useful to include both firmwares to cover all cases for this device.

Signed-off-by: David Lechner <david@lechnology.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/linux-firmware/Config.in
package/linux-firmware/linux-firmware.mk

index bb88afeec23bd049b1cd44f65e8d791e1d227d9c..dcc8d4badeb5fe79a8a49b2104d2dd9567eabfa3 100644 (file)
@@ -282,6 +282,11 @@ config BR2_PACKAGE_LINUX_FIRMWARE_REDPINE_RS9113
        help
          Firmware files for WLAN and Bluetooth modules rs9113
 
+config BR2_PACKAGE_LINUX_FIRMWARE_TI_CC2560
+       bool "TI CC2560"
+       help
+         Firmware files for Bluetooth modules CC2560 and CC2560A
+
 config BR2_PACKAGE_LINUX_FIRMWARE_TI_WL127X
        bool "TI wl127x"
        help
index e5cd56d9a5ea8ba723e96505b29771b6ce04ab85..ee02c7a0301c376e0a1bbc7b82b6e7ab0f66b457 100644 (file)
@@ -249,6 +249,14 @@ LINUX_FIRMWARE_FILES += ath10k/QCA6174
 LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENSE.QualcommAtheros_ath10k
 endif
 
+# CC2560(A)
+ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_TI_CC2560),y)
+LINUX_FIRMWARE_FILES += \
+       ti-connectivity/TIInit_6.2.31.bts \
+       ti-connectivity/TIInit_6.6.15.bts
+LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.ti-connectivity
+endif
+
 # wl127x
 ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_TI_WL127X),y)
 # wl1271-nvs.bin is a symlink to wl127x-nvs.bin