added fltk
authorJohn Voltz <john.voltz@gmail.com>
Thu, 6 Mar 2008 18:09:12 +0000 (18:09 -0000)
committerJohn Voltz <john.voltz@gmail.com>
Thu, 6 Mar 2008 18:09:12 +0000 (18:09 -0000)
package/fltk/Config.in [new file with mode: 0644]
package/fltk/fltk-1.1.7-tests.patch [new file with mode: 0644]
package/fltk/fltk.mk [new file with mode: 0644]

diff --git a/package/fltk/Config.in b/package/fltk/Config.in
new file mode 100644 (file)
index 0000000..08184bf
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_FLTK
+       bool "fltk"
+       default n
+       depends on BR2_PACKAGE_XORG||BR2_PACKAGE_XORG7
+       help
+         a cross-platform C++ GUI toolkit for UNIX/Linux (X11), Microsoft Windows, and MacOS X.
+
+         http://www.fltk.org/
+
+comment "fltk          - disabled (requires Xorg(7))"
+       depends !(BR2_PACKAGE_XORG || BR2_PACKAGE_XORG7)
diff --git a/package/fltk/fltk-1.1.7-tests.patch b/package/fltk/fltk-1.1.7-tests.patch
new file mode 100644 (file)
index 0000000..32d4981
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/test/Makefile    2006-01-15 13:36:16.000000000 -0500
++++ b/test/Makefile    2008-02-12 13:34:25.000000000 -0500
+@@ -230,7 +230,7 @@ uninstall-osx:
+ # FLUID file rules
+ .fl.cxx .fl.h:        ../fluid/fluid$(EXEEXT)
+       echo Generating $<...
+-      ../fluid/fluid$(EXEEXT) -c $<
++      /usr/bin/fluid$(EXEEXT) -c $<
+ # All demos depend on the FLTK library...
+ $(ALL): ../lib/$(LIBNAME)
diff --git a/package/fltk/fltk.mk b/package/fltk/fltk.mk
new file mode 100644 (file)
index 0000000..3558024
--- /dev/null
@@ -0,0 +1,21 @@
+#############################################################
+#
+# fltk
+#
+#############################################################
+
+FLTK_VERSION = 1.1.7
+FLTK_SOURCE = fltk-$(FLTK_VERSION)-source.tar.bz2
+FLTK_SITE = http://ftp.easysw.com/pub/fltk/1.1.7/
+FLTK_AUTORECONF = NO
+FLTK_INSTALL_STAGING = YES
+FLTK_INSTALL_TARGET = YES
+FLTK_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
+
+FLTK_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) --prefix=/usr \
+               --sysconfdir=/etc 
+
+FLTK_DEPENDENCIES = uclibc $(XSERVER) 
+
+$(eval $(call AUTOTARGETS,package,fltk))
\ No newline at end of file