package/openocd: require wchar for the xds110 driver
authorBaruch Siach <baruch@tkos.co.il>
Thu, 1 Jul 2021 14:54:07 +0000 (17:54 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 3 Jul 2021 21:35:14 +0000 (23:35 +0200)
The xds110 driver requires wchar, and is enabled by default. Make sure
to disable xds110 when wchar support is missing.

Fixes:
http://autobuild.buildroot.net/results/530bfe22ff509cf4ebfdf99a183312a1053f505f/
http://autobuild.buildroot.net/results/956538a0a6029137db19cce30dc340e2e30dd166/
http://autobuild.buildroot.net/results/ae7da2ce1389ece44a4ca65108fee02e318df7b3/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/openocd/Config.in
package/openocd/openocd.mk

index f2e79f29fe10698d7e09a03b592f64cc468406ec..b14f940b278bc59bc22157860e7974ac1229851f 100644 (file)
@@ -144,6 +144,15 @@ config BR2_PACKAGE_OPENOCD_ARMEW
          Enable building support for the Olimex ARM-JTAG-EW
          Programmer (default is auto)
 
+config BR2_PACKAGE_OPENOCD_XDS110
+       bool "TI XDS110 Debug Probe"
+       depends on BR2_USE_WCHAR
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # libusb
+       select BR2_PACKAGE_LIBUSB
+       help
+         Enable building support for the TI XDS110 Debug Probe.
+
 config BR2_PACKAGE_OPENOCD_PARPORT
        bool "pc parallel port driver"
        help
@@ -233,4 +242,8 @@ comment "many openocd adapters needs a toolchain w/ threads, gcc >= 4.9"
        depends on !BR2_TOOLCHAIN_HAS_THREADS || \
                !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
 
+comment "xds110 adapter support needs toolchain w/ wchar"
+       depends on !BR2_USE_WCHAR
+       depends on BR2_TOOLCHAIN_HAS_THREADS && BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
+
 endif # BR2_PACKAGE_OPENOCD
index b74426ff4701398fe64703cf6a9df6e9959292c1..9f53ae3ee390251aecd52126b3cd54f76f9af9c1 100644 (file)
@@ -49,6 +49,7 @@ OPENOCD_CONF_OPTS += \
        $(if $(BR2_PACKAGE_OPENOCD_VSLLINK),--enable-vsllink,--disable-vsllink) \
        $(if $(BR2_PACKAGE_OPENOCD_USBPROG),--enable-usbprog,--disable-usbprog) \
        $(if $(BR2_PACKAGE_OPENOCD_RLINK),--enable-rlink,--disable-rlink) \
+       $(if $(BR2_PACKAGE_OPENOCD_XDS110),--enable-xds110,--disable-xds110) \
        $(if $(BR2_PACKAGE_OPENOCD_ARMEW),--enable-armjtagew,--disable-armjtagew) \
        $(if $(BR2_PACKAGE_OPENOCD_CMSIS_DAP),--enable-cmsis-dap,--disable-cmsis-dap) \
        $(if $(BR2_PACKAGE_OPENOCD_PARPORT),--enable-parport,--disable-parport) \