python: bump to 2.7.10
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 16 Jun 2015 21:36:11 +0000 (23:36 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 22 Jun 2015 21:13:46 +0000 (23:13 +0200)
Patches are simply refreshed, except
004-sysconfigdata-install-location.patch where a minor conflict
resolution was needed.

[Peter: fixup .hash as pointed out by Arnout]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
24 files changed:
package/python/004-sysconfigdata-install-location.patch
package/python/005-pyc-pyo-conditional.patch
package/python/006-cross-compile-getaddrinfo.patch
package/python/007-disable-extensions.patch
package/python/010-fix-python-config.patch
package/python/013-dont-add-multiarch-path.patch
package/python/100-optional-test-modules.patch
package/python/101-optional-pydoc.patch
package/python/102-optional-2to3.patch
package/python/103-optional-sqlite.patch
package/python/104-optional-tk.patch
package/python/105-optional-curses.patch
package/python/106-optional-expat.patch
package/python/107-optional-codecs-cjk.patch
package/python/108-optional-nis.patch
package/python/109-optional-unicodedata.patch
package/python/110-optional-db.patch
package/python/111-optional-ssl.patch
package/python/112-optional-bzip2.patch
package/python/113-optional-zlib.patch
package/python/114-remove-idle-editor.patch
package/python/115-optional-ossaudiodev.patch
package/python/python.hash
package/python/python.mk

index a72db1ae790953f5e105234419ba488a4848a9b9..edf7120e12241fa43586be07110d7bf0908e9678 100644 (file)
@@ -69,8 +69,8 @@ Index: b/configure.ac
            AC_MSG_ERROR([python$PACKAGE_VERSION interpreter not found])
        fi
          AC_MSG_RESULT($interp)
--      PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib:$(srcdir)/Lib/plat-$(MACHDEP) '$interp
-+      PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pysysconfigdatadir.txt && echo $(abs_builddir)/`cat pysysconfigdatadir.txt`:)$(srcdir)/Lib:$(srcdir)/Lib/plat-$(MACHDEP) '$interp
+-      PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib:$(srcdir)/Lib/$(PLATDIR) '$interp
++      PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pysysconfigdatadir.txt && echo $(abs_builddir)/`cat pysysconfigdatadir.txt`:)$(srcdir)/Lib:$(srcdir)/Lib/$(PLATDIR) '$interp
      fi
  elif test "$cross_compiling" = maybe; then
      AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
index 0a2f727bb00670987f1d8d72c3504f84532e3870..1b677dfb11532ddb458b24ae49e9a8b53e99a56c 100644 (file)
@@ -39,7 +39,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -736,6 +736,17 @@
+@@ -739,6 +739,17 @@
      ;;
  esac
  
index ba6e6f0a05d3c5b0ef435afb7b5c1610658fe5db..dd44ec15586c742813e7e7b58f89f9751ef9c388 100644 (file)
@@ -2,7 +2,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3346,7 +3346,7 @@
+@@ -3353,7 +3353,7 @@
  
  AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)
  
index be4d9437ae0deadce3d19f832f80104bfe4454a5..9365cb1f5b3438ebda316e0d725b94d27bacfcfa 100644 (file)
@@ -33,9 +33,9 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2284,6 +2284,8 @@
+@@ -2290,6 +2290,8 @@
  
- AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
+ PKG_PROG_PKG_CONFIG
  
 +AC_SUBST(DISABLED_EXTENSIONS)
 +
index 2beb2333bdde44c125eae163a79109799a6ddbf4..1266f3d3af0b15a62440fca584a379f71d0773a1 100644 (file)
@@ -10,7 +10,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -882,6 +882,7 @@
+@@ -885,6 +885,7 @@
  
  # Other platforms follow
  if test $enable_shared = "yes"; then
@@ -18,7 +18,7 @@ Index: b/configure.ac
    AC_DEFINE(Py_ENABLE_SHARED, 1, [Defined if Python is built as a shared library.])
    case $ac_sys_system in
      BeOS*)
-@@ -942,6 +943,7 @@
+@@ -945,6 +946,7 @@
  
    esac
  else # shared is disabled
@@ -26,7 +26,7 @@ Index: b/configure.ac
    case $ac_sys_system in
      CYGWIN*)
            BLDLIBRARY='$(LIBRARY)'
-@@ -1918,6 +1920,9 @@
+@@ -1921,6 +1923,9 @@
  AC_SUBST(BLDSHARED)
  AC_SUBST(CCSHARED)
  AC_SUBST(LINKFORSHARED)
@@ -36,7 +36,7 @@ Index: b/configure.ac
  # SO is the extension of shared libraries `(including the dot!)
  # -- usually .so, .sl on HP-UX, .dll on Cygwin
  AC_MSG_CHECKING(SO)
-@@ -4581,7 +4586,7 @@
+@@ -4588,7 +4593,7 @@
  AC_SUBST(ENSUREPIP)
  
  # generate output files
index 24e7af9ff4305ba444b3d844bec2d8b9db8a5f9d..94fcb0f7fb2b0297f44d57d19409a21bcb134844 100644 (file)
@@ -14,7 +14,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -456,9 +456,9 @@
+@@ -445,9 +445,9 @@
          if not cross_compiling:
              add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
              add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
index 1180b29060e9a44c9eb88d329e957ba87015c12e..3de6f2669d8bbbeedabc3de41ac86692b1ad90d6 100644 (file)
@@ -79,7 +79,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2628,6 +2628,12 @@
+@@ -2634,6 +2634,12 @@
  fi
  
  
index d5dc3d72f913938694fcd96347d7ad81adabec2b..143e11ab9279f007681bfc2e34adc888563b5ae5 100644 (file)
@@ -40,7 +40,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2627,6 +2627,11 @@
+@@ -2633,6 +2633,11 @@
        AC_CHECK_FUNCS(pthread_atfork)
  fi
  
@@ -56,7 +56,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -2222,6 +2222,12 @@
+@@ -2211,6 +2211,12 @@
      # turn off warnings when deprecated modules are imported
      import warnings
      warnings.filterwarnings("ignore",category=DeprecationWarning)
@@ -69,7 +69,7 @@ Index: b/setup.py
      setup(# PyPI Metadata (PEP 301)
            name = "Python",
            version = sys.version.split()[0],
-@@ -2242,9 +2248,7 @@
+@@ -2231,9 +2237,7 @@
            ext_modules=[Extension('_struct', ['_struct.c'])],
  
            # Scripts to install
index 76edfa102fac3c925c452d6f275b838fdf9af02c..100c417a21856299988c342f340df9a9d5863dc3 100644 (file)
@@ -52,7 +52,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2639,6 +2639,12 @@
+@@ -2645,6 +2645,12 @@
        AS_HELP_STRING([--disable-test-modules], [disable test modules]),
        [ TEST_MODULES="${enableval}" ], [ TEST_MODULES=yes ])
  
@@ -69,7 +69,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -2223,10 +2223,11 @@
+@@ -2212,10 +2212,11 @@
      import warnings
      warnings.filterwarnings("ignore",category=DeprecationWarning)
  
index eb43c7a029da45a99bce2cc6bb208b05afa0d63d..3a480119195730e97d21bb81d46b23fd344b7677 100644 (file)
@@ -12,7 +12,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2627,6 +2627,15 @@
+@@ -2633,6 +2633,15 @@
        AC_CHECK_FUNCS(pthread_atfork)
  fi
  
index f402e420fa2569e405b32cacd5ac2f353df8a86a..18024d3a1ea630008d6877fe0d36c615461e6166 100644 (file)
@@ -48,7 +48,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2636,6 +2636,15 @@
+@@ -2642,6 +2642,15 @@
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
  fi
  
index a73fb04e314912dbd0bea4bb1339b6592d58c897..9e1ac5ad54c6cd365ef0ae28bf999e95b14f4dba 100644 (file)
@@ -36,7 +36,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2645,6 +2645,15 @@
+@@ -2651,6 +2651,15 @@
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
  fi
  
index 1ee117cecfd6b01928fef10c0353018ce8e19fa9..6ebaf166d1fbd73823db7b612391fc9fb8895aa5 100644 (file)
@@ -43,7 +43,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2292,13 +2292,21 @@
+@@ -2298,13 +2298,21 @@
  AC_SUBST(DISABLED_EXTENSIONS)
  
  # Check for use of the system expat library
@@ -74,7 +74,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -1474,7 +1474,7 @@
+@@ -1463,7 +1463,7 @@
          #
          # More information on Expat can be found at www.libexpat.org.
          #
index 6329b0ccadddac6e332db85e0107d529c1d2b9f3..22a2fed8b8a7ab06a96e20b9c933b6d6763e6cb9 100644 (file)
@@ -10,7 +10,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2644,6 +2644,12 @@
+@@ -2650,6 +2650,12 @@
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
  fi
  
index f07bbb610f0eeac46090e832b4a09c44f1fffa21..d19ebe1e07eaaf7122fa5a6f6b345aefe18ecc44 100644 (file)
@@ -13,7 +13,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2650,6 +2650,12 @@
+@@ -2656,6 +2656,12 @@
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _codecs_kr _codecs_jp _codecs_cn _codecs_tw _codecs_hk"
          fi])
  
index 10da1ea78fb12674862f8baf5274ff36f3fbb055..841f2a77b57795997646002cc0c8273bda7635e2 100644 (file)
@@ -10,7 +10,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2656,6 +2656,12 @@
+@@ -2662,6 +2662,12 @@
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
          fi])
  
index 4b54e24cd5211b8a28515633a4836d2a0ff141b9..b8c454c90b84af7ec9c7e0dbaaff9d75c9f7324d 100644 (file)
@@ -49,7 +49,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2656,6 +2656,28 @@
+@@ -2662,6 +2662,28 @@
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
          fi])
  
index 72891cd5961ac249e7e8daa699ae455364126d72..956d2a0726fbaa9c98e3885ecec6487a25f6d746 100644 (file)
@@ -10,7 +10,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2656,6 +2656,12 @@
+@@ -2662,6 +2662,12 @@
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
          fi])
  
index 3a646e17ae4fa60a34d70a3ed17ece64c2eddd7c..99fe83ca694aff7c090041e8199fee12ae261fa4 100644 (file)
@@ -9,7 +9,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2662,6 +2662,12 @@
+@@ -2668,6 +2668,12 @@
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl"
          fi])
  
index a4ca8bd441e93897bb5707584afe4e373c6b27a5..652a586eae05c78f693d831b146bb51f7b9a2381 100644 (file)
@@ -9,7 +9,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2668,6 +2668,12 @@
+@@ -2674,6 +2674,12 @@
              DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} bz2"
           fi])
  
index 67b9050b15026de3ac7159924250cdeaac42b45b..512eedcb5fc2cc93fb9886527bd780388eda61eb 100644 (file)
@@ -32,7 +32,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -2223,7 +2223,7 @@
+@@ -2212,7 +2212,7 @@
      import warnings
      warnings.filterwarnings("ignore",category=DeprecationWarning)
  
index de820368e0ac238d449399076976eae107e4d977..89335ba2d0066bb658eb4db45a2fff5497ec2e5b 100644 (file)
@@ -8,11 +8,11 @@ Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
  configure.ac | 6 ++++++
  1 file changed, 6 insertions(+)
 
-diff --git a/configure.ac b/configure.ac
-index e8cb52a..579e05b 100644
+Index: b/configure.ac
+===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2717,6 +2717,12 @@ if test "$CURSES" = "no"; then
+@@ -2726,6 +2726,12 @@
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _curses _curses_panel"
  fi
  
@@ -25,6 +25,3 @@ index e8cb52a..579e05b 100644
  AC_SUBST(PYDOC)
  
  AC_ARG_ENABLE(pydoc,
--- 
-2.1.0
-
index f741e854ad0cb1bd99a85516fb345f60e58e1359..ef8dd981209f52ce01a9a9e8bc91c620f6eff1cc 100644 (file)
@@ -1,2 +1,4 @@
-# Locally calculated after checking pgp signature
-sha256 90d27e14ea7e03570026850e2e50ba71ad20b7eb31035aada1cf3def8f8d4916        Python-2.7.9.tar.xz
+# From https://www.python.org/downloads/release/python-2710/
+md5    c685ef0b8e9f27b5e3db5db12b268ac6        Python-2.7.10.tar.xz
+# Locally calculated
+sha256 1cd3730781b91caf0fa1c4d472dc29274186480161a150294c42ce9b5c5effc0        Python-2.7.10.tar.xz
index 4a3e71c8a4b3660d2b8812eb9a329624df24144a..80ffbdeeee74de151f466a01ffcee1d8bbf20132 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 PYTHON_VERSION_MAJOR = 2.7
-PYTHON_VERSION = $(PYTHON_VERSION_MAJOR).9
+PYTHON_VERSION = $(PYTHON_VERSION_MAJOR).10
 PYTHON_SOURCE = Python-$(PYTHON_VERSION).tar.xz
 PYTHON_SITE = http://python.org/ftp/python/$(PYTHON_VERSION)
 PYTHON_LICENSE = Python software foundation license v2, others