package/vlc: add optional dependency to libsamplerate
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:22 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 10:00:51 +0000 (12:00 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index edd0c3637231050d3a442b039eb8d659cf5ab98a..9e1dc6b92e9155f11ab01430af2c4f09f4430c40 100644 (file)
@@ -51,7 +51,6 @@ VLC_CONF_OPTS += \
        --disable-mmal-vout \
        --disable-mtp \
        --disable-projectm \
-       --disable-samplerate \
        --disable-schroedinger \
        --disable-shout \
        --disable-twolame \
@@ -262,6 +261,13 @@ else
 VLC_CONF_OPTS += --disable-svg --disable-svgdec
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSAMPLERATE),y)
+VLC_CONF_OPTS += --enable-samplerate
+VLC_DEPENDENCIES += libsamplerate
+else
+VLC_CONF_OPTS += --disable-samplerate
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSSH2),y)
 VLC_CONF_OPTS += --enable-sftp
 VLC_DEPENDENCIES += libssh2