clamav: add optional systemd dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 12 Dec 2018 22:22:38 +0000 (23:22 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 13 Dec 2018 20:31:26 +0000 (21:31 +0100)
clamav has an optional systemd dependency

Moreover, since the bump to 1.5.3, pkgconf prepends the sysroot to all
absolute paths found in the .pc file. This is correct when the paths
refer to something in STAGING_DIR (e.g. libdir, includedir), but not
when it refers to something used for the target.

clamav uses the systemdsystemunitdir variable from systemd.pc to decide
where to install things. Since DESTDIR is prepended to the install
destination, this will end up in the wrong location.

Until a better solution is found in pkgconf, pass the
systemdsystemunitdir to use explicitly instead of relying on systemd.pc.

Fixes:
 - http://autobuild.buildroot.org/results/fe526c60542527112e6441e453b4df5de49242d9

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/clamav/clamav.mk

index 50990abad6e9d869ba879b0307724b6ff9441bcb..25ae24054589e389fa134a2429f09fbc24baeab6 100644 (file)
@@ -85,4 +85,11 @@ else
 CLAMAV_CONF_OPTS += --without-pcre
 endif
 
+ifeq ($(BR2_INIT_SYSTEMD),y)
+CLAMAV_CONF_OPTS += --with-systemdsystemunitdir=/usr/lib/systemd/system
+CLAMAV_DEPENDENCIES += systemd
+else
+CLAMAV_CONF_OPTS += --with-systemdsystemunitdir=no
+endif
+
 $(eval $(autotools-package))