package/python3-regex: add special package variant for the host build
authorYegor Yefremov <yegorslists@googlemail.com>
Mon, 23 Mar 2020 10:49:04 +0000 (11:49 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 24 Apr 2020 12:57:00 +0000 (14:57 +0200)
Needed to build mongodb.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-regex/python-regex.mk
package/python3-regex/python3-regex.hash [new symlink]
package/python3-regex/python3-regex.mk [new file with mode: 0644]

index aea967c9eddea5c6b97533f843ba57574fc8a90d..8a527c8ee76149046bfad80a78d00b31039b9c03 100644 (file)
@@ -4,6 +4,7 @@
 #
 ################################################################################
 
+# Please keep in sync with package/python3-regex/python3-regex.mk
 PYTHON_REGEX_VERSION = 2020.2.20
 PYTHON_REGEX_SOURCE = regex-$(PYTHON_REGEX_VERSION).tar.gz
 PYTHON_REGEX_SITE = https://files.pythonhosted.org/packages/e8/76/8ac7f467617b9cfbafcef3c76df6f22b15de654a62bea719792b00a83195
diff --git a/package/python3-regex/python3-regex.hash b/package/python3-regex/python3-regex.hash
new file mode 120000 (symlink)
index 0000000..274f4dc
--- /dev/null
@@ -0,0 +1 @@
+../python-regex/python-regex.hash
\ No newline at end of file
diff --git a/package/python3-regex/python3-regex.mk b/package/python3-regex/python3-regex.mk
new file mode 100644 (file)
index 0000000..f75fb76
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# python3-regex
+#
+################################################################################
+
+# Please keep in sync with package/python-regex/python-regex.mk
+PYTHON3_REGEX_VERSION = 2020.2.20
+PYTHON3_REGEX_SOURCE = regex-$(PYTHON3_REGEX_VERSION).tar.gz
+PYTHON3_REGEX_SITE = https://files.pythonhosted.org/packages/e8/76/8ac7f467617b9cfbafcef3c76df6f22b15de654a62bea719792b00a83195
+PYTHON3_REGEX_SETUP_TYPE = setuptools
+PYTHON3_REGEX_LICENSE = CNRI-Python
+HOST_PYTHON3_REGEX_DL_SUBDIR = python-regex
+HOST_PYTHON3_REGEX_NEEDS_HOST_PYTHON = python3
+
+$(eval $(host-python-package))