woff2: new package
authorAdrian Perez de Castro <aperez@igalia.com>
Fri, 23 Mar 2018 18:59:40 +0000 (20:59 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 24 Mar 2018 10:47:24 +0000 (11:47 +0100)
Add the woff2 package to Builroot. This is needed by webkitgtk from
version 2.20.0 onwards. WebKitGTK+ used to bundle a copy of the library,
but it stopped doing so now that the upstream is has been making
releases.

[Peter: fix license hash]
Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
DEVELOPERS
package/Config.in
package/woff2/Config.in [new file with mode: 0644]
package/woff2/woff2.hash [new file with mode: 0644]
package/woff2/woff2.mk [new file with mode: 0644]

index 2d5f2108a85f1591ad1f175a624ea3a2891d749d..031af3cdd003913ec6188df7eb9450e0311f8c38 100644 (file)
@@ -65,6 +65,7 @@ N:    Adrian Perez de Castro <aperez@igalia.com>
 F:     package/brotli/
 F:     package/libepoxy/
 F:     package/webkitgtk/
+F:     package/woff2/
 
 N:     Adrien Gallouët <adrien@gallouet.fr>
 F:     package/glorytun/
index 26ded5ebb2227803618d5bff35905dc98802c54a..ae5a09bd5b28fd49e430db618c14f2f527b1b7a4 100644 (file)
@@ -1186,6 +1186,7 @@ menu "Graphics"
        source "package/waylandpp/Config.in"
        source "package/webkitgtk/Config.in"
        source "package/webp/Config.in"
+       source "package/woff2/Config.in"
        source "package/zbar/Config.in"
        source "package/zxing-cpp/Config.in"
 endmenu
diff --git a/package/woff2/Config.in b/package/woff2/Config.in
new file mode 100644 (file)
index 0000000..4867257
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_WOFF2
+       bool "woff2"
+       depends on BR2_INSTALL_LIBSTDCPP
+       select BR2_PACKAGE_BROTLI
+       help
+         Reference implementation for the WOFF2 font file format,
+         typically used for Web fonts
+
+         https://github.com/google/woff2
diff --git a/package/woff2/woff2.hash b/package/woff2/woff2.hash
new file mode 100644 (file)
index 0000000..469071e
--- /dev/null
@@ -0,0 +1,5 @@
+# Locally generated:
+sha512  c788bba1530aec463e755e901f9342f4b599e3a07f54645fef1dc388ab5d5c30625535e5dd38e9e792e04a640574baa50eeefb6b7338ab403755f4a4e0c3044d  v1.0.2.tar.gz
+
+# Hash for license files:
+sha512  8ee924da3fb5d16135adcf6a8fbe9e2e8f3d2d80468617e72ca4fa059a60f8455c9a5f68a8dc381b1297c8bf39c887a912d0f69246d2604ada74d3da9e8e490b  LICENSE
diff --git a/package/woff2/woff2.mk b/package/woff2/woff2.mk
new file mode 100644 (file)
index 0000000..23b88a5
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# woff2
+#
+################################################################################
+
+WOFF2_VERSION = 1.0.2
+WOFF2_SOURCE = v$(WOFF2_VERSION).tar.gz
+WOFF2_SITE = https://github.com/google/woff2/archive
+WOFF2_LICENSE = MIT
+WOFF2_LICENSE_FILES = LICENSE
+WOFF2_INSTALL_STAGING = YES
+WOFF2_DEPENDENCIES = brotli
+WOFF2_CONF_OPTS = \
+       -DNOISY_LOGGING=OFF
+
+$(eval $(cmake-package))