uclibc: do not enable DODEBUG
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 11 Dec 2013 21:56:21 +0000 (22:56 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 12 Dec 2013 15:25:45 +0000 (16:25 +0100)
The DODEBUG configuration option in uClibc is broken, even for widely
used architectures like ARM. Therefore, any Buildroot configuration
that has BR2_ENABLE_DEBUG enabled and uses uClibc with the internal
toolchain backend will fail, with an error like:

  http://autobuild.buildroot.net/results/d34/d34238c209cf2ef63371a598ab9218165c90f864/build-end.log

This error was also reported recently by a Buildroot user.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/uclibc/uclibc.mk

index de9011f6145d53a0c201fdc028ed179daa3bf61b..9e047711cec2e83ddf604404532568cafaf7d7df 100644 (file)
@@ -390,14 +390,6 @@ else
 UCLIBC_WCHAR_CONFIG = $(call UCLIBC_OPT_UNSET,UCLIBC_HAS_WCHAR,$(@D))
 endif
 
-#
-# debug
-#
-
-ifeq ($(BR2_ENABLE_DEBUG),y)
-UCLIBC_DEBUG_CONFIG = $(call UCLIBC_OPT_SET,DODEBUG,y,$(@D))
-endif
-
 #
 # strip
 #
@@ -448,7 +440,6 @@ define UCLIBC_SETUP_DOT_CONFIG
        $(UCLIBC_LOCALE_CONFIG)
        $(UCLIBC_WCHAR_CONFIG)
        $(UCLIBC_STRIP_CONFIG)
-       $(UCLIBC_DEBUG_CONFIG)
        yes "" | $(MAKE1) -C $(@D) \
                $(UCLIBC_MAKE_FLAGS) \
                PREFIX=$(STAGING_DIR) \