package/tz: install missing files
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 4 May 2014 16:01:28 +0000 (18:01 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 4 May 2014 21:03:15 +0000 (23:03 +0200)
As for the tzdata package, install the missing files:
  - zone.tab   : {country-code,coordinates,timezone} tuples
  - iso3166.tab: {country-code,country} tuples

Reported-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tz/tz.mk

index a762acd0b0d3dfe40a710dfef3a3600ea0e599a9..865ba3bb9c2bb86813200631ce28e665d7b12765 100644 (file)
@@ -20,6 +20,10 @@ define TZ_BUILD_CMDS
 endef
 
 define TZ_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0644 $(HOST_DIR)/usr/share/zoneinfo/zone.tab \
+                             $(TARGET_DIR)/usr/share/zoneinfo/zone.tab
+       $(INSTALL) -D -m 0644 $(HOST_DIR)/usr/share/zoneinfo/iso3166.tab \
+                             $(TARGET_DIR)/usr/share/zoneinfo/iso3166.tab
        mkdir -p $(TARGET_DIR)/usr/share/zoneinfo/uclibc
        cp -a $(@D)/output/* $(TARGET_DIR)/usr/share/zoneinfo/uclibc
        if [ -n "$(TZ_LOCALTIME)" ]; then                               \