package/kodi-pvr-stalker: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 22 Jul 2015 20:30:47 +0000 (22:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 30 Jul 2015 07:37:45 +0000 (09:37 +0200)
[Thomas:
   - use a shorter file as the license file, client.h instead of client.cpp
   - do not pass -DCMAKE_MODULE_PATH, no longer needed.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/kodi-pvr-stalker/Config.in [new file with mode: 0644]
package/kodi-pvr-stalker/kodi-pvr-stalker.mk [new file with mode: 0644]
package/kodi/Config.in

index 90466506d915fb829b0a1d0a7c3e4c0a1abdc280..718bf66cb3a4a28bc4775971b9973997d411ff94 100644 (file)
@@ -121,6 +121,7 @@ config BR2_PACKAGE_KODI_PVR_ADDONS
        select BR2_PACKAGE_KODI_PVR_NEXTPVR
        select BR2_PACKAGE_KODI_PVR_NJOY
        select BR2_PACKAGE_KODI_PVR_PCTV
+       select BR2_PACKAGE_KODI_PVR_STALKER
        help
          Kodi PVR addon was split into seperate modules
 
diff --git a/package/kodi-pvr-stalker/Config.in b/package/kodi-pvr-stalker/Config.in
new file mode 100644 (file)
index 0000000..b327fd8
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_KODI_PVR_STALKER
+       bool "kodi-pvr-stalker"
+       select BR2_PACKAGE_KODI_PLATFORM
+       help
+         A PVR Client that connects Kodi to Stalker Middleware
+
+         https://github.com/kodi-pvr/pvr.stalker
diff --git a/package/kodi-pvr-stalker/kodi-pvr-stalker.mk b/package/kodi-pvr-stalker/kodi-pvr-stalker.mk
new file mode 100644 (file)
index 0000000..589cf7d
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# kodi-pvr-stalker
+#
+################################################################################
+
+KODI_PVR_STALKER_VERSION = 5f6eb1992ffd45a075ebb7bc4253c4a88bf65c80
+KODI_PVR_STALKER_SITE = $(call github,kodi-pvr,pvr.stalker,$(KODI_PVR_STALKER_VERSION))
+KODI_PVR_STALKER_LICENSE = GPLv2+
+KODI_PVR_STALKER_LICENSE_FILES = src/client.h
+KODI_PVR_STALKER_DEPENDENCIES = kodi-platform
+
+$(eval $(cmake-package))
index 7c9709ea845d9d2717e389382c2536c79b7a0330..93c14233f889d787600a4de733fc05c4bd6d8c77 100644 (file)
@@ -269,6 +269,7 @@ menu "PVR addons"
        source "package/kodi-pvr-nextpvr/Config.in"
        source "package/kodi-pvr-njoy/Config.in"
        source "package/kodi-pvr-pctv/Config.in"
+       source "package/kodi-pvr-stalker/Config.in"
 endmenu
 
 endif # BR2_PACKAGE_KODI