ncmpc: fix build with ncursesw
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 1 Apr 2018 17:56:51 +0000 (19:56 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 1 Apr 2018 22:08:38 +0000 (00:08 +0200)
Fixes:
http://autobuild.buildroot.net/results/c5bb5f978602896179ff9c58ecf4ced40bb96b57

When ncurses is built with wide support, we install libncursesw (plus a
libncurses symlink) but NOT ncursesw.h, only ncurses.h.  This combination
confuses the ncmpc build system as it expects a ncursesw.h when it finds
libncursesw:

meson.build:92:4: ERROR: Problem encountered: No ncursesw header found

The ncurses/ncursesw logic in the build system is only used to know what
header file to #include, and what library to link with.  As we already
provide a libncurses symlink when building with wide support we can simply
force ncmpc to use the ncurses variant.

[Peter: extend commit message]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ncmpc/ncmpc.mk

index 0c9dfd46583fcc24ae2e50c1ed66cb3833b53686..6bce627562bf3b698298073dfcb36df3f9b0bf06 100644 (file)
@@ -14,6 +14,7 @@ NCMPC_LICENSE_FILES = COPYING
 
 NCMPC_CONF_OPTS += \
        --prefix=/usr \
+       -Dcurses=ncurses \
        --buildtype $(if $(BR2_ENABLE_DEBUG),debug,release) \
        --cross-file $(HOST_DIR)/etc/meson/cross-compilation.conf