package/systemd: add a menu entry to enable portable services
authorFrancois Gervais <FGervais@distech-controls.com>
Thu, 26 Nov 2020 15:55:33 +0000 (10:55 -0500)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 15 Dec 2020 21:00:55 +0000 (22:00 +0100)
Signed-off-by: Francois Gervais <fgervais@distech-controls.com>
Reviewed-by: Norbert Lange <nolange79@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/systemd/Config.in
package/systemd/systemd.mk

index ec34478e3d1617fec04f649e49e1aa98d4f58db5..fbe1a4081b85c8f51b01ec7182ec6f2d53051a25 100644 (file)
@@ -343,6 +343,24 @@ comment "polkit support needs a toolchain with C++, wchar, NPTL, gcc >= 4.9"
                !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || \
                !BR2_USE_WCHAR
 
+config BR2_PACKAGE_SYSTEMD_PORTABLED
+       bool "enable portable services"
+       help
+         Portable services are systemd services that can be dynamically
+         attached and detached from the system.
+
+         These services must come with their own root directory which
+         they are bound to through an automatically generated drop-in.
+
+         They also have restrictions applied by the host system in the
+         form of profiles.
+
+         This functionality is provided by the system service
+         systemd-portabled along with the corresponding CLI
+         portablectl.
+
+         https://systemd.io/PORTABLE_SERVICES/
+
 config BR2_PACKAGE_SYSTEMD_QUOTACHECK
        bool "enable quotacheck tools"
        help
index cb12f667d6ecff1b8c269af17b0b9cb423aa81c3..5aed87f452be8c56195512deb99f84b8419ebadc 100644 (file)
@@ -33,7 +33,6 @@ SYSTEMD_CONF_OPTS += \
        -Dman=false \
        -Dmount-path=/usr/bin/mount \
        -Dnss-systemd=true \
-       -Dportabled=false \
        -Dquotacheck-path=/usr/sbin/quotacheck \
        -Dquotaon-path=/usr/sbin/quotaon \
        -Drootlibdir='/usr/lib' \
@@ -417,6 +416,12 @@ else
 SYSTEMD_CONF_OPTS += -Dpolkit=false
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_PORTABLED),y)
+SYSTEMD_CONF_OPTS += -Dportabled=true
+else
+SYSTEMD_CONF_OPTS += -Dportabled=false
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_NETWORKD),y)
 SYSTEMD_CONF_OPTS += -Dnetworkd=true
 SYSTEMD_NETWORKD_USER = systemd-network -1 systemd-network -1 * - - - systemd Network Management