xcb-util: add dependency on libxcb
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 7 Mar 2013 10:18:29 +0000 (10:18 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 9 Mar 2013 11:10:52 +0000 (12:10 +0100)
The xcb-util lacks a dependency on libxcb. Without this dependency, it
fails to build with:

checking for XCB... no
configure: error: in `/home/thomas/projets/buildroot/output/build/xcb-util-0.3.9':
configure: error: The pkg-config script could not be found or is too old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

Alternatively, you may set the environment variables XCB_CFLAGS
and XCB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/x11r7/xcb-util/Config.in
package/x11r7/xcb-util/xcb-util.mk

index cf7932735388752d463ddb0bd02faca482bce816..dd77b1d9d4f24be184a2c90ac2643d7ffb76dd0d 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_XCB_UTIL
        bool "xcb-util"
+       depends on BR2_PACKAGE_LIBXCB
        help
          Libraries which sit on top of libxcb, the core X protocol library,
          and some of the extension libraries.
index fcf99ea671c75193a035635393e57ddbb3472028..a1948e1c24e6f85fd95c2a6eed9598e5d3907b48 100644 (file)
@@ -7,7 +7,7 @@ XCB_UTIL_VERSION = 0.3.9
 XCB_UTIL_SOURCE = xcb-util-$(XCB_UTIL_VERSION).tar.bz2
 XCB_UTIL_SITE = http://xcb.freedesktop.org/dist/
 XCB_UTIL_INSTALL_STAGING = YES
-XCB_UTIL_DEPENDENCIES = host-gperf
+XCB_UTIL_DEPENDENCIES = host-gperf libxcb
 
 $(eval $(autotools-package))