python-mutagen: new package
authorAdam Duskett <Aduskett@gmail.com>
Wed, 25 Jan 2017 16:26:10 +0000 (11:26 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 26 Jan 2017 08:06:19 +0000 (21:06 +1300)
Mutagen is a Python module to handle audio metadata.
It supports ASF, FLAC, MP4, Monkey’s Audio, MP3, Musepack, Ogg Opus,
Ogg FLAC, Ogg Speex, Ogg Theora, Ogg Vorbis, True Audio, WavPack,
OptimFROG, and AIFF audio files. All versions of ID3v2 are supported,
and all standard ID3v2.4 frames are parsed.

It can read Xing headers to accurately calculate the bitrate and
length of MP3s. ID3 and APEv2 tags can be edited regardless of
audio format. It can also manipulate Ogg streams on an individual
packet/page level.

Mutagen works with Python 2.7, 3.3+ (CPython and PyPy) on Linux,
Windows and macOS, and has no dedependencies outside the
Python standard library.

Signed-off-by: Adam Duskett <aduskett@codeblue.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
[Thomas:
 - fix license, it's GPLv2, not LGPLv2+
 - rewrap Config.in help text]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-mutagen/Config.in [new file with mode: 0644]
package/python-mutagen/python-mutagen.hash [new file with mode: 0644]
package/python-mutagen/python-mutagen.mk [new file with mode: 0644]

index c7b686232f5499579a0bab72e4daabb0610250e4..0023e7bee8dfc3cd0b19bc026c06780955ed9500 100644 (file)
@@ -724,6 +724,7 @@ menu "External python modules"
        source "package/python-meld3/Config.in"
        source "package/python-mistune/Config.in"
        source "package/python-msgpack/Config.in"
+       source "package/python-mutagen/Config.in"
        source "package/python-mwclient/Config.in"
        source "package/python-mwscrape/Config.in"
        source "package/python-mwscrape2slob/Config.in"
diff --git a/package/python-mutagen/Config.in b/package/python-mutagen/Config.in
new file mode 100644 (file)
index 0000000..470cd99
--- /dev/null
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_PYTHON_MUTAGEN
+       bool "python-mutagen"
+       select BR2_PACKAGE_PYTHON_PYEXPAT if BR2_PACKAGE_PYTHON # runtime
+       select BR2_PACKAGE_PYTHON3_PYEXPAT if BR2_PACKAGE_PYTHON3 # runtime
+       select BR2_PACKAGE_PYTHON_ZLIB if BR2_PACKAGE_PYTHON # runtime
+       select BR2_PACKAGE_PYTHON3_ZLIB if BR2_PACKAGE_PYTHON3 # runtime
+       help
+         Mutagen is a Python module to handle audio metadata.  It
+         supports ASF, FLAC, MP4, Monkey’s Audio, MP3, Musepack, Ogg
+         Opus, Ogg FLAC, Ogg Speex, Ogg Theora, Ogg Vorbis, True
+         Audio, WavPack, OptimFROG, and AIFF audio files. All
+         versions of ID3v2 are supported, and all standard ID3v2.4
+         frames are parsed.
+
+         It can read Xing headers to accurately calculate the bitrate
+         and length of MP3s. ID3 and APEv2 tags can be edited
+         regardless of audio format.  It can also manipulate Ogg
+         streams on an individual packet/page level.
+
+         https://mutagen.readthedocs.io/en/latest/
diff --git a/package/python-mutagen/python-mutagen.hash b/package/python-mutagen/python-mutagen.hash
new file mode 100644 (file)
index 0000000..8970a23
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/mutagen, sha256 locally computed
+md5    2bd50519d64411626fa22d405afbf078  mutagen-1.36.tar.gz
+sha256 d7ee37e33b8c5893c3ebf66edac31241eb9d48e1dc7ec647bbfbc180565a4bcd  mutagen-1.36.tar.gz
diff --git a/package/python-mutagen/python-mutagen.mk b/package/python-mutagen/python-mutagen.mk
new file mode 100644 (file)
index 0000000..8458de5
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-mutagen
+#
+################################################################################
+
+PYTHON_MUTAGEN_VERSION = 1.36
+PYTHON_MUTAGEN_SOURCE = mutagen-$(PYTHON_MUTAGEN_VERSION).tar.gz
+PYTHON_MUTAGEN_SITE = https://pypi.python.org/packages/69/14/4a5c8360a727563291a7159de935ffff2b99ee783928169f0fea7445370f
+PYTHON_MUTAGEN_LICENSE = GPLv2
+PYTHON_MUTAGEN_LICENSE_FILES = COPYING
+PYTHON_MUTAGEN_SETUP_TYPE = distutils
+
+$(eval $(python-package))