gstreamer: update to the latest gstreamer +plugins packages
authorFelipe Contreras <felipe.contreras@gmail.com>
Fri, 4 Feb 2011 18:25:12 +0000 (20:25 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 4 Feb 2011 21:26:09 +0000 (22:26 +0100)
liboil is not needed not used any more. orc _can_ be used instead, but
it's not needed.

[Peter: get rid of liboil selects]
Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gst-plugins-bad/gst-plugins-bad.mk
package/multimedia/gst-plugins-base/Config.in
package/multimedia/gst-plugins-base/gst-plugins-base.mk
package/multimedia/gst-plugins-good/gst-plugins-good.mk
package/multimedia/gst-plugins-ugly/gst-plugins-ugly.mk
package/multimedia/gstreamer/gstreamer-0.10.25-fix-unaligned-detectiob-for-x86-64.patch [deleted file]
package/multimedia/gstreamer/gstreamer.mk

index 7a059c19b6b0aed6c949631d14b755aeec8da26b..c3002562d455bcbeb5934443511875404ba5b5d8 100644 (file)
@@ -3,7 +3,7 @@
 # gst-plugins-bad
 #
 #############################################################
-GST_PLUGINS_BAD_VERSION = 0.10.14
+GST_PLUGINS_BAD_VERSION = 0.10.21
 GST_PLUGINS_BAD_SOURCE = gst-plugins-bad-$(GST_PLUGINS_BAD_VERSION).tar.bz2
 GST_PLUGINS_BAD_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-bad
 GST_PLUGINS_BAD_LIBTOOL_PATCH = NO
@@ -11,7 +11,7 @@ GST_PLUGINS_BAD_LIBTOOL_PATCH = NO
 GST_PLUGINS_BAD_CONF_OPT = \
                --disable-examples
 
-GST_PLUGINS_BAD_DEPENDENCIES = gst-plugins-base gstreamer liboil
+GST_PLUGINS_BAD_DEPENDENCIES = gst-plugins-base gstreamer
 
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AACPARSE),y)
 GST_PLUGINS_BAD_CONF_OPT += --enable-aacparse
index 0f552fe2b6187dc4cc9f83db1a0804c4f2871293..09c243cb6f1807e2add598de19d84efe33d372b3 100644 (file)
@@ -1,7 +1,6 @@
 menuconfig BR2_PACKAGE_GST_PLUGINS_BASE
        bool "gst-plugins-base"
        depends on BR2_PACKAGE_GSTREAMER
-       select BR2_PACKAGE_LIBOIL
        help
          A basic set of well-supported plug-ins for GStreamer.
 
index e91d5fc0de0707f8601db1fde0826d25528acbc3..828d156c026adb986fe92087dbef33f1b4d42278 100644 (file)
@@ -3,7 +3,7 @@
 # gst-plugins-base
 #
 #############################################################
-GST_PLUGINS_BASE_VERSION = 0.10.25
+GST_PLUGINS_BASE_VERSION = 0.10.32
 GST_PLUGINS_BASE_SOURCE = gst-plugins-base-$(GST_PLUGINS_BASE_VERSION).tar.bz2
 GST_PLUGINS_BASE_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-base
 GST_PLUGINS_BASE_INSTALL_STAGING = YES
@@ -25,7 +25,7 @@ GST_PLUGINS_BASE_CONF_OPT = \
                --disable-vorbistest \
                --disable-freetypetest
 
-GST_PLUGINS_BASE_DEPENDENCIES = gstreamer liboil
+GST_PLUGINS_BASE_DEPENDENCIES = gstreamer
 
 # alsa support needs pcm+mixer support, but configure fails to check for it
 ifeq ($(BR2_PACKAGE_ALSA_LIB)$(BR2_PACKAGE_ALSA_LIB_MIXER)$(BR2_PACKAGE_ALSA_LIB_PCM),yyy)
index f7a20872403f8c5acc5921537bd63114f658a200..7a67dc5cf449263e8cd0c97b2672e987dd2b279a 100644 (file)
@@ -3,7 +3,7 @@
 # gst-plugins-good
 #
 #############################################################
-GST_PLUGINS_GOOD_VERSION = 0.10.16
+GST_PLUGINS_GOOD_VERSION = 0.10.27
 GST_PLUGINS_GOOD_SOURCE = gst-plugins-good-$(GST_PLUGINS_GOOD_VERSION).tar.bz2
 GST_PLUGINS_GOOD_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-good
 GST_PLUGINS_GOOD_LIBTOOL_PATCH = NO
index fc2fcffe73f82f137b3c0b885660e7cc43d4d968..4eb02e5094e27be71d35861866fefc8eb667a202 100644 (file)
@@ -3,7 +3,7 @@
 # gst-plugins-ugly
 #
 #############################################################
-GST_PLUGINS_UGLY_VERSION = 0.10.10
+GST_PLUGINS_UGLY_VERSION = 0.10.17
 GST_PLUGINS_UGLY_SOURCE = gst-plugins-ugly-$(GST_PLUGINS_UGLY_VERSION).tar.bz2
 GST_PLUGINS_UGLY_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-ugly
 GST_PLUGINS_UGLY_LIBTOOL_PATCH = NO
diff --git a/package/multimedia/gstreamer/gstreamer-0.10.25-fix-unaligned-detectiob-for-x86-64.patch b/package/multimedia/gstreamer/gstreamer-0.10.25-fix-unaligned-detectiob-for-x86-64.patch
deleted file mode 100644 (file)
index 1635fe7..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-[PATCH] gst-arch.m4: fix unaligned detection for x86-64 when cross compiling
-
-Submitted upstream at https://bugzilla.gnome.org/show_bug.cgi?id=607317
-
-Commit 4221e9dc (amd64/x86_64 allows unaligned memory access too) added
-x86-64 to the unaligned access whitelist, but missed the trailing
-wildcards, so the test never succeeds (host is something like
-x86_64-unknown-linux-gnu).
-
-When building natively, this isn't a big deal as the AC_TRY_RUN test
-correctly detects it, but that doesn't work when cross compiling so
-the build dies with:
-
-configure: error: cannot run test program while cross compiling
-See `config.log' for more details.
-
-Fix it by adding the trailing wildcards.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- configure |    2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-Index: gstreamer-0.10.25/configure
-===================================================================
---- gstreamer-0.10.25.orig/configure
-+++ gstreamer-0.10.25/configure
-@@ -15655,7 +15655,7 @@ $as_echo_n "checking if unaligned memory
-         $as_echo_n "(blacklisted) " >&6
-         as_cv_unaligned_access=no
-       ;;
--      i?86*|x86_64|amd64|powerpc*|m68k*|cris*)
-+      i?86*|x86_64*|amd64*|powerpc*|m68k*|cris*)
-         $as_echo_n "(whitelisted) " >&6
-         as_cv_unaligned_access=yes
-       ;;
index d689619ed74ba4a38f83b1396df372ad3a37ba7c..558d4764010ada58fad25ad5e77439850bbf3bdd 100644 (file)
@@ -3,7 +3,7 @@
 # gstreamer
 #
 #############################################################
-GSTREAMER_VERSION = 0.10.25
+GSTREAMER_VERSION = 0.10.32
 GSTREAMER_SOURCE = gstreamer-$(GSTREAMER_VERSION).tar.bz2
 GSTREAMER_SITE = http://gstreamer.freedesktop.org/src/gstreamer
 GSTREAMER_INSTALL_STAGING = YES