libfreefare: examples need to link with zlib for openssl when static linking
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 9 Jan 2014 10:23:56 +0000 (11:23 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 9 Jan 2014 10:23:56 +0000 (11:23 +0100)
Fixes http://autobuild.buildroot.net/results/f09/f09d515f0e7b6d78010f1ce624336ceaef624989/

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libfreefare/libfreefare.mk

index 8dcd6b81c9b7a4807e145216ff029a6bd7d509de..362cab2fa6a21f9098ddeefa878cf59d1a600d01 100644 (file)
@@ -8,4 +8,9 @@ LIBFREEFARE_VERSION = 0.3.4
 LIBFREEFARE_SITE = http://libfreefare.googlecode.com/files
 LIBFREEFARE_DEPENDENCIES = libnfc openssl
 
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+# openssl needs zlib even if the libfreefare example itself doesn't
+LIBFREEFARE_CONF_ENV += LIBS='-lz'
+endif
+
 $(eval $(autotools-package))