toolchain: generate a gdbinit file
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 5 May 2014 09:25:50 +0000 (11:25 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 5 May 2014 11:31:30 +0000 (13:31 +0200)
This commit slightly improves the external toolchain backend, and the
gdb build logic to create a file named
$(STAGING_DIR)/usr/share/buildroot/gdbinit which can be used as a
gdbinit file using gdb -x option. This allows gdb to automatically use
the proper sysroot to find libraries.

The initial insight for this patch comes from the report of Oded
Hanson <OHanson@xsightsys.com>, who found an issue with the Eclipse
Buildroot plugin, which was setting a solib-path in gdb, but not a
sysroot. Setting a solib-path was enough to find shared libraries, but
not the dynamic linker. And since Eclipse doesn't allow to set the
sysroot in any other way than giving a gdbinit file, it makes sense to
have Buildroot generate a gdbinit file (which can be used in other
situations than Eclipse).

To achieve this, this commit introduces a gen_gdbinit_file helper in
toolchain/helpers.mk, and uses it for the internal toolchain and
external toolchain backends.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
[ThomasDS: minor updates in commit message]
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gdb/gdb.mk
toolchain/helpers.mk
toolchain/toolchain-external/toolchain-external.mk

index 69fb3bae21e57e496dce2d9e059fc62ac6a3eb9c..678c17cfd9a48657f9e4f624003ba8c5024872bc 100644 (file)
@@ -126,5 +126,7 @@ endef
 
 HOST_GDB_POST_INSTALL_HOOKS += HOST_GDB_ADD_SYMLINK
 
+HOST_GDB_POST_INSTALL_HOOKS += gen_gdbinit_file
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))
index 9595196e9bf2195f67b719b2470ef7439070849d..ef60120713aef77149c98a53c6e0fb59460259f6 100644 (file)
@@ -355,3 +355,10 @@ check_unusable_toolchain = \
                echo "such as Buildroot." ; \
                exit 1 ; \
        fi
+
+#
+# Generate gdbinit file for use with Buildroot
+#
+gen_gdbinit_file = \
+       mkdir -p $(STAGING_DIR)/usr/share/buildroot/ ; \
+       echo "set sysroot $(STAGING_DIR)" > $(STAGING_DIR)/usr/share/buildroot/gdbinit
index b40f54dd7ebd24a3002102d751a623eac5a0c321..05d8867a81217e73dc580b6698ce0dfd2adbc790 100644 (file)
@@ -651,6 +651,12 @@ define TOOLCHAIN_EXTERNAL_SANITIZE_KERNEL_HEADERS
                -e 's@#(ifndef|define|endif[ \t]*/[*])[ \t]*_UAPI@#\1 @'
 endef
 
+define TOOLCHAIN_EXTERNAL_INSTALL_GDBINIT
+       if test -f $(TARGET_CROSS)gdb ; then \
+               $(call gen_gdbinit_file) ; \
+       fi
+endef
+
 # Even though we're installing things in both the staging, the host
 # and the target directory, we do everything within the
 # install-staging step, arbitrarily.
@@ -659,6 +665,7 @@ define TOOLCHAIN_EXTERNAL_INSTALL_STAGING_CMDS
        $(TOOLCHAIN_EXTERNAL_INSTALL_BFIN_FDPIC)
        $(TOOLCHAIN_EXTERNAL_INSTALL_BFIN_FLAT)
        $(TOOLCHAIN_EXTERNAL_INSTALL_WRAPPER)
+       $(TOOLCHAIN_EXTERNAL_INSTALL_GDBINIT)
 endef
 
 $(eval $(generic-package))