package/sqlcipher: fix static build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 9 Mar 2019 16:28:15 +0000 (17:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 9 Mar 2019 20:46:55 +0000 (21:46 +0100)
Fixes:
 - http://autobuild.buildroot.org/results/ebd8678a56a7dd8679fd4ec3ca1385c04866cc88

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sqlcipher/sqlcipher.mk

index fcca3b72543d5d0703e5bede74fa76728e18d745..44273441202759bbdfceb0aaf8e0c74f4d3d4ed9 100644 (file)
@@ -33,4 +33,10 @@ else
 SQLCIPHER_CONF_OPTS += --disable-readline
 endif
 
+ifeq ($(BR2_STATIC_LIBS),y)
+SQLCIPHER_CONF_OPTS += --disable-load-extension
+else
+SQLCIPHER_CONF_OPTS += --enable-load-extension
+endif
+
 $(eval $(autotools-package))